在线检测未来函数

判断顶底的区域背离指标(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

用法说明:本指标起着指示技术指标低、中、高区域和显示KDJMACDRSI顶底背离的作用。实战操作中方便投资者集中查阅这3种价格类指标的差离、协同情况,对股价运动起着辅助研判的作用。
短高、短低对应日线级别,波高、波低区域对应周线级别,中高、中低区域对应月线级别时间周期。

CHECK1:=CHECKUSER(1);
POLYLINE(1,"KDJ.D"),colorFFFF00;
短高:IF(BETWEEN("KDJ.K",100,80),88,100),PRECISION0;
短低:IF(BETWEEN("KDJ.K",20,0),12,0),PRECISION0;
波低:IF(BETWEEN("KDJ.K#week",10,0),30,0),PRECISION0;
波高:IF(BETWEEN("KDJ.K#week",100,90),70,100),PRECISION0;
中低:IF(BETWEEN("KDJ.K#MONTH",20,0),30,0),PRECISION0,colorFF;
中高:IF(BETWEEN("KDJ.K#MONTH",100,75),70,100),PRECISION0;
POLYLINE(1,0),colorFFFF;
A1:=BARSLAST(REF(CROSS("MACD.DIFF","MACD.DEA"),1));
B1:=REF(CLOSE,A1+1)>CLOSE AND REF("MACD.DIFF",A1+1)<"MACD.DIFF" AND CROSS("MACD.DIFF","MACD.DEA");
MACD底背离:STICKLINE(FILTER(B1>0,5),0,25,3,0),colorFF00;
DRAWTEXT(FILTER(B1>0,5),25,'MACD底背'),colorFF00;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(CLOSE,A2+1)>CLOSE AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
KDJ底背离:STICKLINE(FILTER(B2>0,5),0,25,3,0),colorFFFF;
DRAWTEXT(FILTER(B2>0,5),25,'KDJ底背'),colorFFFF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(CLOSE,A3+1)>CLOSE AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
RSI底背离:STICKLINE(FILTER(B3>0,5),0,25,3,0),colorFFFF00;
DRAWTEXT(FILTER(B3>0,5),25,'RSI底背'),colorFFFF00;
POLYLINE(1,100),colorFF;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIFF"),1));
D1:=REF(CLOSE,C1+1)<CLOSE AND REF("MACD.DIFF",C1+1)>"MACD.DIFF" AND CROSS("MACD.DEA","MACD.DIFF");
MACD顶背离:STICKLINE(FILTER(D1>0,5),100,75,3,0),color66FF;
DRAWTEXT(FILTER(D1>0,5),75,'MACD顶背'),color66FF;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(CLOSE,C2+1)<CLOSE AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
KDJ顶背离:STICKLINE(FILTER(D2>0,5),100,75,3,0),colorFF;
DRAWTEXT(FILTER(D2>0,5),75,'KDJ顶背'),colorFF;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(CLOSE,C3+1)<CLOSE AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
RSI顶背离:STICKLINE(FILTER(D3>0,5),100,75,3,0),colorFF00FF;
DRAWTEXT(FILTER(D3>0,5),75,'RSI顶背'),colorFF00FF;

 

相关文章