在线检测未来函数

KDJ改进指标公式2010金典版(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:SMA(RSV,3,1),colorred;

D:SMA(K,3,1),COLORblue;
J:=3*K-2*D;
v1:=if (high>=hhv(high,8) and k<hhv(k,63) and k<=ref(k,1),1,0);
v2:=if (low<=llv(low,8) and k>=llv(k,63) and k>=ref(k,1),1,0);
drawicon(cross(k,d) and k<=20,d,10);
drawicon(cross(d,k),d,11);
drawicon(cross(k,d) and k<=45 and k>20,d,12);
drawicon(v1,50,9);
drawicon(v2,50,8);
交叉位:=((3*REF(D,1)-2*REF(K,1))*(HHV(H,8)-LLV(L,8))/100)+LLV(L,8);
n1:=sysparam(3); n2:=sysparam(2); n3:=(n1-n2)+1; hh:=hhv(J,n3); ll:=llv(J,n3);
zhh:=hh[n1]; zll:=ll[n1];
预测价:交叉位 , ColorFF8EFF;
DRAWTEXT(BARPOS=SYSPARAM(3)&&交叉位<C,zhh,'预测死叉价: '+NUMTOSTR(交叉位,3)),ALIGN2,SHIFT3,PXDN10,ColorFF8E00;
DRAWTEXT(BARPOS=SYSPARAM(3)&&交叉位>C,zll,'预测金叉价: '+NUMTOSTR(交叉位,3)),ALIGN2,SHIFT3,PXUP10,ColorFF8EFF;

 

相关文章