在线检测未来函数

自用操盘手QSDD指标优化(通达信)

来源:Internet,编辑:股旁网,2010-05-24

{自用QSDD优化}
STICKLINE(DDX>0,0,DDX,1,0 ),COLOR0022CC;
STICKLINE(DDX<0,0,DDX,1,0 ),COLORFFFF00;
DDX1:=EMA(DDX,60)*20,COLOR00FFFF;
DDX2:=MA(DDX1,5),COLORFF00FF;
DDX3:MA(DDX1,7),COLOR00FF00,LINETHICK2;
DD1:=EMA(IF(L<= LLV(L,99),SMA(ABS(L-REF(L,1)),
99,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3)*5,COLORYELLOW;
DD2:=EMA(IF(L<= LLV(L,55),SMA(ABS(L-REF(L,1)),
55,1)/SMA(MAX(L-REF(L,1),0),55,1),0)*5,3)*5,COLORGREEN;
DD3:=EMA(IF(L<= LLV(L,25),SMA(ABS(L-REF(L,1)),
25,1)/SMA(MAX(L-REF(L,1),0),25,1),0)*5,3)*5,COLORMAGENTA;
D1:STICKLINE(DD3,DD3,0,5,-2),COLORMAGENTA;
D2:STICKLINE(DD2,DD2,0,5,-2),COLORGREEN;
D3:STICKLINE(DD1,DD1,0,3,-2),COLORYELLOW;
80,COLOR996699;
20,COLORGREEN;
10,COLORCC6633,LINETHICK2;
90,COLOR9966FF,LINETHICK2;
{50,COLORRED;
FILLRGN(1,20,80),COLOR222222;
FILLRGN(1,90,100),COLOR000068;
FILLRGN(1,79,90),COLOR663366;
FILLRGN(1,10,20),COLOR666600;
FILLRGN(1, 0,10),COLOR663300;}
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
RSV1:=(C-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*20;
K1:=SMA(RSV1,5,1);
DA:=SMA(K1,21,1);
短期线:(3*K1-2*DA)*5,COLOR888888;
长期线:A+100,COLOR9900FF;
{短期线:B+100,COLORBLUE;}
中期线:D+100,COLORYELLOW,LINETHICK2;
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线)) ,COLORGREEN;
顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4,COLORGREEN;
顶部:=FILTER(顶部区域,4);
STICKLINE( {见顶 OR} 顶部,99,103,20,1 ),COLORRED,LINETHICK2;
底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ,COLORGREEN;
STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN;
低位金叉:50*(长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 )),LINETHICK2,COLORRED;
STICKLINE( 低位金叉,0,5,11,0 ),COLORRED;(源码来自网络与操盘手QSDD一样)

相关文章