在线检测未来函数

掌股专家指标修改修改版(通达信)

来源:Internet,编辑:股旁网,2010-05-24

通达信版{涨停先锋}---修改并稍作优化
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
{AVX:(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)))/50;}
风向标:MA((((((IF(A5,100,0) + IF(A6,100,0)) + IF(A7,100,0)) + IF(A8,100,0)) + IF(A9,100,0)) + IF(A11,100,0))/6,3.5);
{VARR:=REF(CLOSE,1);强弱方向:=SMA(MAX(CLOSE-VARR,0),5,1)/SMA(ABS(CLOSE- VARR),5,1)*100,COLORYELLOW;}
{80, POINTDOT,COLORBLUE,LINETHICK2;
70, POINTDOT,COLORWHITE,LINETHICK2;
20, POINTDOT,COLORGREEN,LINETHICK2;
{10, POINTDOT,COLORBLUE,LINETHICK2};
航向: MA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,3,1)-2*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,3,1),3);
选股一帆风顺:IF(风向标<35 AND 航向<35 AND CROSS(风向标,航向),60,0);
DRAWICON(风向标<35 AND 航向<35 AND CROSS(风向标,航向),选股一帆风顺,25);
DRAWTEXT(风向标<35 AND 航向<35 AND CROSS(风向标,航向),0,'扬帆');

 

通达信版{资金动能}
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD := 2*(DIFF-DEA);
X1:=EMA(DIFF,5)*5;
X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
X3:IF(X2>0,X2,0),COLORRED;
STICKLINE(X2>0,0,X2,2,-1),COLORRED;
X4:IF(X2<0,X2,0),COLORGREEN;
STICKLINE(X2<0,0,X2,2,-1),COLORGREEN;
资金动能A:X2,LINETHICK1,COLORBROWN;
资金动能B:X1,LINETHICK1,COLORBLUE;
选股:IF(CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25,1,0);
DRAWICON((CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25),资金动能B,1);
DRAWICON((CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25),选股,26);

 

相关文章