在线检测未来函数

通达信超赢鬼脸指标公式

来源:Internet,编辑:股旁网,2010-05-24

超赢鬼脸源码帮你挣钱

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
STICKLINE(A>B,A,B,5,0),COLORYELLOW;
STICKLINE(A<B,A,B,5,0),COLORBLUE;
M1:EMA(CLOSE,3);
M2:EMA(CLOSE,8);
M3:EMA(M2,13);
M4:EMA(M2,55);
VAR1:=EMA(M3,55);
M5:EMA(M4,81), COLORRED,LINETHICK2;

VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);
DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,2);
DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,'卖出'), COLORGREEN;
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),7,1)/SMA(ABS(CLOSE-VAR4),7,1)*100;
VAR6:=CROSS(79,VAR5);
VAR7:=FILTER(VAR6,4);
DRAWICON(VAR7,HIGH*1.035,2);
DRAWTEXT(VAR7,HIGH*1.02,'卖出'), COLORGREEN;
A7:=(2*C+H+L)/4;
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'●买进') ,COLORRED;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW,'●买进'), COLORRED;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'●抄底'),COLORRED;
VAR111:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR222:=REF(VAR111,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR333:=REF(VAR222,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR444:=REF(VAR333,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR555:=REF(VAR444,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR666:=REF(VAR555,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR777:=REF(VAR666,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR888:=REF(VAR777,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR999:=REF(VAR888,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR999,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR111 OR VAR222 OR VAR333 OR VAR444 OR VAR555 OR VAR666 OR VAR777 OR VAR888 OR VAR999 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR1110:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR1111:=REF(VAR1110,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR1112:=REF(VAR1111,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR1113:=REF(VAR1112,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR1114:=REF(VAR1113,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR1115:=REF(VAR1114,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR1116:=REF(VAR1115,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR1117:=REF(VAR1116,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR1118:=REF(VAR1117,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR1110 OR VAR1111 OR VAR1112 OR VAR1113 OR VAR1114 OR VAR1115 OR VAR1116 OR VAR1117 OR VAR1118,CLOSE,REF(CLOSE,1),3,1),COLORLIBLUE;
VAR1119:=REF(VARD OR VARE OR VARF OR VAR1110 OR VAR1111 OR VAR1112 OR VAR1113 OR VAR1114 OR VAR1115 OR VAR1116 OR VAR1117 OR VAR1118,1) AND VAR111;
STICKLINE(VAR1119,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA;
VAR111A:=REF(VAR111 OR VAR222 OR VAR333 OR VAR444 OR VAR555 OR VAR666 OR VAR777 OR VAR888 OR VAR999 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR111A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR008800;

 

相关文章