在线检测未来函数

通达信全能换手指标公式

来源:Internet,编辑:股旁网,2010-05-24

m1:=5;
m2:=40;
m3:=135;
换手:VOL/CAPITAL*100,COLORYELLOW;
预计换手:IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1))/CAPITAL*100,0);
STICKLINE(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VOL,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1)),7,-21),COLOR66CCCC;
十日换手:SUM(换手,10);

预测量:IF(CURRBARSCOUNT=1 AND PERIOD=5,AMO*240/FROMOPEN,AMO),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预测量,0,-1,-1),COLOR00C0C0;
实际成交:AMO,VOLSTICK;
上涨放量:STICKLINE(预测量/REF(AMO,1)>=1.5 AND C>REF(C,1),AMO,0,2.2,0),COLORYELLOW;
动态天量:IF(REF(V,1)=HHV(V,20),REF(V,1),REF(REF(V,1),BARSLAST(REF(V,1)=HHV(V,20)))),COLORFFCC66;
动态地量:IF(AMO=LLV(AMO,20),AMO,REF(AMO,BARSLAST(AMO=LLV(AMO,20)))),COLORYELLOW;
STICKLINE(预测量=动态地量 AND 动态地量<REF(动态地量,0),动态天量,动态地量,1,0),COLORGRAY;
IF(预测量=动态地量 AND 动态地量<REF(动态地量,1),动态地量,DRAWNULL),LINETHICK3,COLORRED;
MAV5:MA(实际成交,M1),COLORRED;
MAV40:MA(实际成交,M2),COLORGREEN;
MAV135:MA(实际成交,M3),COLOR808000;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主卖:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
买比:主买/VOL*100,COLORRED;
{STICKLINE(C<REF(C,1),0,V,8,0),COLOR999900;
STICKLINE(C>=REF(C,1),0,V,8,0),COLOR0000E5;
STICKLINE(VOL,0,VOL,6,0),COLOR555500;
STICKLINE(VOL,0,VOL,5,0),COLOR888800;
STICKLINE(VOL,0,VOL,4,0),COLORAAAA00;
STICKLINE(VOL,0,VOL,3,0),COLORCCCC00;
STICKLINE(VOL,0,VOL,2,0),COLOREEEE00;
STICKLINE(VOL,0,VOL,1,0),COLORFFFF00;
STICKLINE(主买,0,主买,6,0),COLOR000055;
STICKLINE(主买,0,主买,5,0),COLOR000088;
STICKLINE(主买,0,主买,4,0),COLOR0000AA;
STICKLINE(主买,0,主买,3,0),COLOR0000CC;
STICKLINE(主买,0,主买,2,0),COLOR0000EE;
STICKLINE(主买,0,主买,1,0),COLOR0000FF;}
STICKLINE(换手>25,0,V*-300,5,0),COLORGREEN;
STICKLINE(换手>2 AND 换手<=3,0,V*-200,7,0),COLORWHITE;
STICKLINE(换手>3 AND 换手<=5,0,V*-200,7,0),COLORFF0000;
STICKLINE(换手>5 AND 换手<=8,0,V*-200,7,0),COLORYELLOW;
STICKLINE(换手>8 AND 换手<=15,0,V*-200,7,0),COLORFF22EE;
STICKLINE(换手>15,0,V*-200,7,0),COLOR0000FF;
VAR2:=0.0001*AMOUNT;
MA1:=0.0001*MA(AMOUNT,5);
MA2:=0.0001*MA(AMOUNT,10);
百日地量:=LLV(VAR2,100)=VAR2,STICK,COLORRED,LINETHICK4;
DRAWTEXT(百日地量,0.3,'地量'),COLORRED;

 

相关文章