在线检测未来函数

通达信BBD动能操盘指标公式

来源:Internet,编辑:股旁网,2010-05-24

AL:=(C+L+H)/3;
AO:=SMA(AL,5,1)-SMA(AL,13,1);
BBD:(AO-SMA(AO, 3,1))*100,COLORFFCCFF,NODRAW;
{动能线定义}
动能线:AO*10,COLORRED;
动能辅线:EMA(AO,5)*10,COLOR00FF00;
{动能线强弱分界带} {GUPIAOFF.COM}
DRAWBAND(动能辅线,RGB(115,95,95),0,RGB(95,95,115));
{动能彩带}
DRAWBAND(动能线,RGB(175,0,55),动能辅线,RGB(55,175,0));
{BBD支撑线定义} {GUPIAOFF.COM}
BBD支撑线:SMA(BBD,5,2),COLOR0033FF,LINETHICK2;
RSV1:=BBD;
RSV2:=BBD支撑线;
弱:IF(BACKSET(RSV2<REF(RSV2,1),1),RSV2,DRAWNULL),LINETHICK2,COLORFF3300;
{BBD彩色柱体}
BBD1:=IF(BBD>=REF(BBD,1),BBD,DRAWNULL);
BBD2:=IF(BBD<REF(BBD,1),BBD,DRAWNULL);
STICKLINE(BBD1,0,BBD,1.5,0),COLOR885588;
STICKLINE(BBD1,0,BBD,1,0),COLORAA77AA;
STICKLINE(BBD1,0,BBD,0.5,0),COLORBB99BB;
STICKLINE(BBD1,0,BBD,0.1,0),COLORDDAADD;
STICKLINE(BBD2,0,BBD,1.5,0),COLOR757500;
STICKLINE(BBD2,0,BBD,1,0),COLORAAAA00;
STICKLINE(BBD2,0,BBD,0.5,0),COLORBBBB00;
STICKLINE(BBD2,0,BBD,0.1,0),COLORDDDD00;
{BBD支撑线金叉死叉顶底背离}
BBD金叉:IF(CROSS(RSV1,RSV2),RSV2,DRAWNULL),CIRCLEDOT,COLORFF33FF;
BBD死叉:IF(CROSS(RSV2,RSV1),RSV2,DRAWNULL),CIRCLEDOT,COLORFFFF00;
SV1:=BARSLAST(REF(CROSS(RSV1,RSV2),1));
SV1A:=REF(CLOSE,SV1+1)>CLOSE AND RSV1>REF(RSV1,SV1+1) AND
CROSS(RSV1,RSV2); {GUPIAOFF.COM}
B底背:IF(SV1A,RSV2,DRAWNULL),COLOR3366FF;
DRAWTEXT(SV1A,RSV2,'─B底背'),COLOR0033FF;
SV2:=BARSLAST(REF(CROSS(RSV2,RSV1),1));
SV2A:=REF(CLOSE,SV2+1)<CLOSE AND REF(RSV1,SV2+1)>RSV1 AND CROSS(RSV2,RSV1);
B顶背:IF(SV2A,RSV2,DRAWNULL),COLORFFFF00;
DRAWTEXT(SV2A,RSV2,'─B顶背'),COLORFFFF00;
{动能线金叉死叉顶底背离}
RSV3:=动能线;
RSV4:=动能辅线;
动能金叉:IF(CROSS(RSV3,RSV4),RSV3,DRAWNULL),CIRCLEDOT,COLOR0000FF;
动能死叉:IF(CROSS(RSV4,RSV3),RSV3,DRAWNULL),CIRCLEDOT,COLOR00FF00;
SV3:=BARSLAST(REF(CROSS(RSV3,RSV4),1));
SV3A:=REF(CLOSE,SV3+1)>CLOSE AND RSV3>REF(RSV3,SV3+1) AND
CROSS(RSV3,RSV4);
动底背:IF(SV3A,RSV3,DRAWNULL),COLOR0000FF;
DRAWTEXT(SV3A,RSV3,'─动底背'),COLOR0000FF;
SV4:=BARSLAST(REF(CROSS(RSV4,RSV3),1));
SV4A:=REF(CLOSE,SV4+1)<CLOSE AND REF(RSV3,SV4+1)>RSV3 AND CROSS(RSV4,RSV3);
动顶背:IF(SV4A,RSV3,DRAWNULL),COLOR00FF00;
DRAWTEXT(SV4A,RSV3,'─动顶背'),COLOR00FF00;

 

相关文章