在线检测未来函数

飞狐KJ饱和度竖显日周月指标公式

来源:Internet,编辑:股旁网,2010-05-24

50,COLORFFBB00;
K:"KDJ.K",PRECISION2,COLORWHITE,LINETHICK;D:="KDJ.D";
J:"KDJ.J",PRECISION2,COLORMAGENTA,LINEDOT;
PARTLINE(K <REF(K,1),K),COLORFFBBBB,LINEDOT;
FILLRGN(K>D,K,D),COLOR0066FF;
{}
Bb:=CROSS(K,D);Ss:=CROSS(D,K);
drawtext(Bb,2,' ↑'),colorred;
drawtext(Bb,2,'B'),colorred;
drawtext(Ss,100,' ↓'),colorwhite;
drawtext(Ss,100,'S'),colorwhite;
{}
RK:=MA("KDJ.K#DAY",1);
ZJ:=MA("KDJ.J#WEEK",5);
YJ:=MA("KDJ.J#MONTH",21);
SAT:IF((AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100),PRECISION2,COLORCCFFCC,LINETHICK;
{}P:=SYSPARAM(1);BD:=BARPOS;ww:=SYSPARAM(2)+4;
STICKLINE(BD=WW,-22,122,84,1),COLORFFFFFF;
STICKLINE(BD=WW-3,1,YJ[p] ,14,0),COLORFFAAAA;
STICKLINE(BD=WW-1,1,ZJ[p] ,14,0),COLORFF6600;
STICKLINE(BD=WW+1,1,RK[p] ,14,0),COLOR0000BB;
STICKLINE(BD=WW+3,1,SAT[p],14,0),COLOR66AA66;
DRAWTEXT(BD=WW-3,YJ[p],' 月J:\n'+NUMTOSTR(YJ[P],2)),COLORWHITE,align0,PXUP30;
DRAWTEXT(BD=WW-1,ZJ[p],' 周J:\n'+NUMTOSTR(ZJ[P],2)),COLORFFEE00,align0,PXUP30;
DRAWTEXT(BD=WW+1,RK[p],' 日K:\n'+NUMTOSTR(RK[P],2)),COLORCCFFCC,align0,PXUP30;
DRAWTEXT(BD=WW+3,SAT[p],'饱和度:\n'+NUMTOSTR(SAT[P],1)),COLORCCFFCC,align0,PXUP30;

 

相关文章