在线检测未来函数

通达信抓住主力指标公式

来源:Internet,编辑:股旁网,2010-05-24

N1:=7;N2:=14;N3:=21;
界:=38,COLORFF3311;
STICKLINE(C>0,38,38,1,1),COLORFF9911;
加仓线:=51,COLORFF1155;
STICKLINE(C>0,51,51,1,1),COLORFF1199;
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFFFFFF;
RSI2:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFFFFFF;
RSI3:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFFFFFF;
RSI4:SMA(RSI3,7,1),LINETHICK2,COLOR00CD00;
趋势F:=XMA(((CLOSE- LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF;
趋势8:=XMA(((CLOSE- LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD;
趋势:EMA(((CLOSE- LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18,COLORYELLOW,LINETHICK2;
WR1:XMA(趋势F,7)*1.372,COLORRED,LINETHICK2;
WR2:=WR1*1.0887;
WRF:(1.5*(趋势 8+RSI4)-(WR2+WR1))+12,COLOR3377FF,COLORRED,LINETHICK2,COLORFF0000;
BUY:IF((CROSS(WR1,趋势) OR CROSS(WR1,WRF) AND WRF<界 AND RSI2<加仓线),48,38),COLORFFFFFF;
XG:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,WRF) AND WRF<界 AND RSI1<加仓线),48,38),COLORFF6655;

 

相关文章