在线检测未来函数

通达信私募操盘轨迹指标公式

来源:Internet,编辑:股旁网,2010-05-24

B:=ZIG(3,50/5)*200;
G:=MA(B,2);

红三角底信号:CROSS(B,G)*300,,COLORRED,LINESTICK,LINETHICK5;黄三角顶信号:CROSS(G,B)*300,,COLORYELLOW,LINESTICK,LINETHICK5;
DRAWICON(CROSS(B,G),H,7);
DRAWICON(CROSS(G,B),H,8);
买:CROSS(B,G)*10,,COLORYELLOW;
卖:CROSS(G,B)*10,,COLOR00FF00;
DRAWTEXT(卖=10,100,'当心见顶' ),COLORRED;
DRAWTEXT(买=10,0,'关注底信号'),COLORRED,LINETHICK5;
QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);

涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
跌:EMA(涨,4),LINETHICK1,COLORFFFF34;
下轨:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK7,COLORFF00FF,;
上轨:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK7;
DRAWICON(CROSS(EMA(QW6,10),EMA(涨,4)=IF(CROSS(涨,跌) AND 跌<-10,30,0)>IF(CROSS(跌,80),70,100)),L,5);

STICKLINE(涨<REF(涨,1),涨,MA(涨,3),8,0 ),COLOR008800;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),8,0) ,COLOR0011FF;

VAR811:=SUMBARS(VOL,FINANCE(7)*100);
VAR822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR883:=(CLOSE-VAR822)/VAR822*100;
VAR884:=HHV(VAR883,VAR811);
VAR885:=LLV(VAR883,VAR811);
VAR886:=(VAR883-VAR885)/(VAR884-VAR885)*100;
K:=SMA(VAR886,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA1:=MA(J,3),COLORGREEN;
STICKLINE(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,涨,涨+20,6,0),COLORYELLOW;

★探底:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
STICKLINE(★探底>0,0,120,2,0),COLORWHITE;

XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
SQX:=MA((CLOSE-XX2)/2,10)*0.01;
稳赚:IF(COUNT(SQX>REF(SQX,1),3)=3 AND COUNT(SQX<0,10)=10 AND REF(SQX,3)=LLV(SQX,10),60,0),COLOR9999FF;
DRAWTEXT( 稳赚>0,50 ,'稳赚'),COLOR9999FF;
VARB:=VOL/CAPITAL*100;
VARE:=HHVBARS(HIGH,50);
VARF:=(CLOSE-REF(OPEN,VARE))/REF(OPEN,VARE)*100;
VAR15:=REF(CLOSE,2)*0.865;
VAR16:=REF(CLOSE,13)*0.772;
VAR17:=MIN(VAR15,VAR16);
超跌: IF((CLOSE-VAR17)/CLOSE<0.03 AND VARF<-35 AND SUM(VARB,5)/5<1.8,1,0)*10, , COLORWHITE;
DRAWTEXT(超跌>0,30,'超跌'),COLORGREEN;
TYP := (HIGH + LOW + CLOSE)/3;
V1:=SUM(IF(TYP>REF(TYP,1),TYP*VOL,0),N)/SUM(IF(TYP<REF(TYP,1),TYP*VOL,0),N);
MFI:100-(100/(1+V1)),COLORYELLOW,LINETHICK2;

 

相关文章