在线检测未来函数

飞狐移动筹码分布指标公式

来源:Internet,编辑:股旁网,2010-05-24

input:N1(250),N2(210),N3(50);
x1:=(C+L+H)/3;
x2:=EMA(x1,6);
x3:=EMA(x2,5);
stickline(x2>x3 and c>ema(x1,13),low,high,0.1,1),colorred;
stickline(x2>x3 and c>ema(x1,13),close,open,5,1),colorred;
stickline(x2<x3 and c<ema(x1,13),low,high,0.1,1),colorffff54;
stickline(x2<x3 and c<ema(x1,13),close,open,5,0),colorffff54;
drawtext(CROSS(X2,X3),l-0.09,'B'),colorred;
gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5));
gr2:=ema(x1,13)>ema(x1,21) and ema(x1,21)>ema(x1,34) and ema(x1,13)>ref(ema(x1,13),1);
gr3:=count("bias.bias2"(6,13,24)>10 and h=hhv(h,gr1),gr1);
gr4:=h=hhv(h,gr1);
gr5:="macd.macd"(12,26,9)<ref("macd.macd"(12,26,9),1);
gr6:=gr2 and gr3 and gr4;
gr7:=gr2 and gr3 and gr4 and gr5;
gr8:=gr6 and gr7;
LC := REF(CLOSE,1);
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
换手:=100*v/capital;
DRAWTEXT(filter(rsi6>95 and 换手>=7,3) or filter(bias5>9,3) or gr8,h*1.04,'S'),color00ff00;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,13),1),10),ema(x1,8),'∠45'),colorblue;
variable:pv[50]=0,pc[50]=0;
hh:=HHV(HIGH,0);
ll:=LLV(LOW,0);
fv:=VOL;
fh:=HIGH;
fl:=LOW;
p:=SYSPARAM(1);
dd:=(hh[p]-ll[p])/49;
for i=p downto 1 do begin
sh:=(fh-ll[p])/dd+1;
sl:=(fl-ll[p])/dd+1;
dj:=fv/(sh-sl+1);
for j=sl to sh do pv[j]:=pv[j]+dj;
end;
s:=0;
for i=1 to 50 do IF s <pv then s:=pv;
bl:=s/(SYSPARAM(3)-SYSPARAM(2))*2;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5),0,pv[1]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd,0,pv[2]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*02,0,pv[03]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*03,0,pv[04]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*04,0,pv[05]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*05,0,pv[06]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*06,0,pv[07]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*07,0,pv[08]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*08,0,pv[09]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*09,0,pv[10]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*10,0,pv[11]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*11,0,pv[12]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*12,0,pv[13]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*13,0,pv[14]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*14,0,pv[15]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*15,0,pv[16]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*16,0,pv[17]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*17,0,pv[18]/bl+1,1),COLORred;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*18,0,pv[19]/bl+1,1),COLORgreen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*19,0,pv[20]/bl+1,1),COLORgreen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*20,0,pv[21]/bl+1,1),COLORgreen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*21,0,pv[22]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*22,0,pv[23]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*23,0,pv[24]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*24,0,pv[25]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*25,0,pv[26]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*26,0,pv[27]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*27,0,pv[28]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*28,0,pv[29]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*29,0,pv[30]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*30,0,pv[31]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*31,0,pv[32]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*32,0,pv[33]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*33,0,pv[34]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*34,0,pv[35]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*35,0,pv[36]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*36,0,pv[37]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*37,0,pv[38]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*38,0,pv[39]/bl+1,1),COLORGReen;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*39,0,pv[40]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*40,0,pv[41]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*41,0,pv[42]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*42,0,pv[43]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*43,0,pv[44]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*44,0,pv[45]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*45,0,pv[46]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*46,0,pv[47]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*47,0,pv[48]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*48,0,pv[49]/bl+1,1),COLORyellow;
DRAWSL(BARPOS=SYSPARAM(3),SYSPARAM(5)+dd*49,0,pv[50]/bl+1,1),COLORyellow;

 

相关文章