在线检测未来函数

通达信量能买卖指标公式

来源:Internet,编辑:股旁网,2010-05-24

万手:VOL/10000,LINETHICK0,NODRAW;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
预测:AA/10000;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,0,3,1),COLORYELLOW;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,
BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:主动买/10000,COLORRED,NODRAW;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),
IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:-主动卖/10000,COLORGREEN,NODRAW;
差额:(主动买+主动卖)/10000,NODRAW;
CC:=(2*C+H+L)/4;
STICKLINE(CC>REF(CC,1),0,VOL,2,DRAWNULL),COLORRED;
STICKLINE(CC<REF(CC,1),0,VOL,2,DRAWNULL),COLORCYAN;
STICKLINE(CC=REF(CC,1),0,VOL,2,DRAWNULL),COLORWHITE;
{STICKLINE(C>-1,0,VOL,3,1),COLORRED;
STICKLINE(C<O ,0,VOL,3,1),COLORFFFF00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2,1),COLORFFFF00;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2,1),COLORRED;}
STICKLINE(主动买>0,0,主动买,1,0),COLOR0000FF;
STICKLINE(主动卖<0,VOL,主动买,1,0),COLOR00FF00;
持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORMAGENTA;
五日: MA(V,5) COLORFFFFFF LINETHICK2;
三十四日: MA(V,34) COLORFF80FF LINETHICK2;
一百四十四日: MA(V,144) COLOR00FFFF LINETHICK1;

 

相关文章