在线检测未来函数

通达信风险评测优化指标公式

来源:Internet,编辑:股旁网,2010-05-24

RSVA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));
VAR21:=SMA(RSVA2,9,1)+100;
VAR11:=SMA(RSVA1,3,1);
VAR51:=SMA(VAR11,3,1)+100;
顶底线:=VAR51-VAR21+50;
VAR2:=LLV(LOW,33);
VAR3:=HHV(HIGH,21);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,10)*-1+100;
趋势:=100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1);
Y:=(L+H)/2;
AO:=SMA(Y,5,1);
AC:=SMA(Y,34,1);
DIFZ:=(AO-AC)*10;
DH:=(SMA(DIFZ-SMA(DIFZ,3,1),2,1))*6,COLORSTICK;
RC:=50,COLORYELLOW,LINETHICK1;
STICKLINE(C,100,90,4,0),COLORFFCC33;
STICKLINE(C,90,80,4,0),COLORFF9933;
STICKLINE(顶底线>REF(顶底线,1),20,80,4,0),COLOR000055;
STICKLINE(顶底线<REF(顶底线,1),20,80,4,0),COLOR663300;
STICKLINE((趋势>REF(趋势,1) AND 顶底线<REF(顶底线,1)),20,80,4,0),COLOR000055;
STICKLINE((趋势<REF(趋势,1) AND 顶底线>REF(顶底线,1)),20,80,4,0),COLOR663300;
STICKLINE(C,20,10,4,0),COLORFF6633;
STICKLINE(C,10,0,4,0),COLORFF3333;

DRAWBAND(DIFZ+RC,RGB(185,50,50),EMA(DIFZ+RC,9),RGB(0,50,190));
DRAWBAND(-DIFZ+RC,RGB(0,50,190),EMA(-DIFZ+RC,9),RGB(185,50,50));
IF(C,DIFZ+RC,DRAWNULL),COLORRED,LINETHICK1;
IF(DIFZ<=REF(DIFZ,1),DIFZ+RC,DRAWNULL),COLORGRAY;
IF(DH>0,RC,DRAWNULL),COLOR2266FF,LINETHICK1;
IF(DH<=0,RC,DRAWNULL),COLORDDDD66,LINETHICK1;
STICKLINE(DH>0 AND DH>REF(DH,1),RC,RC+DH,1,0),COLORRED;
STICKLINE(DH>0 AND DH<=REF(DH,1),RC,RC+DH,1,0),COLORLIGREEN;
STICKLINE(DH<0 AND DH>REF(DH,1),RC,RC+DH,1,0),COLORLIRED;
STICKLINE(DH<0 AND DH<=REF(DH,1),RC,RC+DH,1,0),COLORLIBLUE;

当前安全度:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),LINETHICK1,COLORYELLOW;
DRAWTEXT(ISLASTBAR,5,' 高安全'),COLORWHITE;
DRAWTEXT(ISLASTBAR,15,' 安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,85,' 风险区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,95,' 高风险'),COLORWHITE;

 

相关文章