在线检测未来函数

通达信红顶绿底指标公式

来源:Internet,编辑:股旁网,2010-05-24

RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K0:=SMA(RSV,3,1);
K:=K0;
D:=SMA(K0,2,1);
j1:=(3*k0-2*d);
j2:MA(j1,2),LINETHICK1,colorCYAN;
趋势线:(1.06*(3*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)+50),Color6A826C;
Var5:=AMOUNT/VOL/100;
Var6:=IF(Var5>CLOSE*1.1,CLOSE,IF(Var5<CLOSE*0.9,CLOSE,Var5));
Var7:=100*WINNER(Var6);
Var8:=MA(Var7,8);
Var9:=HHV(CLOSE,0)/Var8;
VarA:=IF(Var9>2.5,-10,Var9);
VarB:=IF(VarA>1,-10,VarA);
底限: VarB, colorgreen;
VarC:=Var8/LLV(LOW,0);
VarD:=HHV(HIGH,0)/Var8*8*10;
VarE:=IF(VarD>50,50,VarD);
VarF:=VarE;
Var10:=HHV(HIGH,0)/Var8*4.5*100;
Var11:=IF(Var10>100,103,Var10);
Var15:=REF(CLOSE,1);
短线:=SMA(MAX(CLOSE-Var15,0),2,1)/SMA(ABS(CLOSE-Var15),2,1)*100;
红顶:STICKLINE(短线>90,91,89,1,0),pointdot,linethick6 ,COLORred;
绿底:STICKLINE(短线<5,11,9,1,0),pointdot,linethick6,Color00FF00;
买入: IF(CROSS(j1,j2) and 底限=-10 and j2<20 or CROSS(j1,j2) and 短线<5,60,19), colorgreen;
卖出: IF(CROSS(j2,j1) and j2>80 and 趋势线>80 or CROSS(87,趋势线),40,81),Color0000FF;
DRAWTEXT(CROSS(87,趋势线),35,'逃'),Color0000FF;
DRAWTEXT(CROSS(j1,j2) and 底限=-10 and j2<20 or CROSS(j1,j2) and 短线<5,65,'买');
DRAWTEXT(CROSS(90,Var8),86,'诱多'), colorgreen;

 

相关文章