在线检测未来函数

通达信MACD双变指标公式

来源:Internet,编辑:股旁网,2010-05-24

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1<MACD2 AND MACD1<0,0,MACD1,2,0),COLORGREEN;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORGREEN;
STICKLINE(MACD1<MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,2),COLORWHITE;
DIF:DIF1,COLORBLUE,LINETHICK2;
DEA:DEA1,COLORGREEN,LINETHICK2;
MACD:MACD1,NODRAW,COLORMAGENTA;
强:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK2;
弱:IF(DIF1<=DEA1,DIF1,DRAWNULL),COLOR33FF33,LINETHICK3;
好:IF(DEA1<=DIF1,DEA1,DRAWNULL),COLORRED,LINETHICK3;
SS:=CROSS(DIF,DEA)
{AND CROSS(DIF,DEA)};
DRAWTEXT(SS,H*0.00088,'●'),COLOR9933FF;
DD:=CROSS(DEA,DIF)
{AND CROSS(DEA,DIF)};
DRAWTEXT(DD,+L*0.00088,'●'),COLORYELLOW;

 

相关文章