在线检测未来函数

通达信黑马摇篮指标公式

来源:Internet,编辑:股旁网,2010-05-24

{用法注解:

黑马线上穿0后持续>10以上时黑马无疑,如600682、600271等。
黑马等于80时请关注。2002年成功率93%,成功944支。
发现=60要关注。
大黑马等于1,2002年成功率91%,320只;

110为第一条指标线与操盘手100联动。
-11为第五条指标线
大黑马=1、发现=60、黑马=80时,2002年选出
600763在110后黑马线上穿O成大牛股。};

{N1(1.00,100.00,14.00)}

VAR3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
VAR4:=(CLOSE-LLV(CLOSE,N1))/(HHV(CLOSE,N1)-LLV(CLOSE,N1))*100;
VAR5:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR6:=EMA(VAR5,100);
VAR7:=2*(VAR5-VAR6);
VAR8:=POW(VAR7,3)*0.1+POW(VAR7,1);
VAR9:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VARA:=EMA(VAR9*0.97,3);
VARB:=(HIGH+LOW+CLOSE)/3;
VARC:=(VARB-MA(VARB,14))/(0.015*AVEDEV(VARB,14));
黑马线1:= IF(VAR7>0.1,VAR8,0)*5;
VARD:=LLV(HIGH,240);
VARE:=100*(CLOSE-VARD)/VARD;
VARF:=AMOUNT/VOL;
VAR10:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
VAR11:=INDEXC;
VAR12:=MA(VAR11,5);
VAR13:=MA(VAR11,20);
VAR14:=MA(VAR11,30);
VAR15:=VAR14>VAR12*1.08 AND VAR13>VAR12*1.055;
VAR16:=VAR12>VAR11*1.03 AND VAR13>VAR11*1.13;
VAR17:=VAR16;
VAR18:=IF(FILTER(VAR10<6,5)=1,1,0);
VAR19:=VAR10<6 AND VAR17;
VAR1A:=CROSS(黑马线1,2);
VAR1B:=CROSS(黑马线1,4);
VAR1C:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR1D:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR1E:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR1F:=REF(CLOSE,1);
VAR20:=SMA(MAX(CLOSE-VAR1F,0),5,1)/SMA(ABS(CLOSE-VAR1F),5,1)*100;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR1C>=-15.8 AND VAR1C<=-12.2 AND VAR1D<=-20.8 AND VAR1E<=-27.5 AND VAR20<=11.7 AND VAR22<=-145)*100;
VAR24:=VAR4=0;
VAR25:=VAR4=100;
IF(VAR25>0,110,101),STICK,LINETHICK2,COLOR00FF00;101,STICK,LINETHICK2,COLOR000000;
IF(VAR23>0,100,90),STICK,LINETHICK3,COLORRED;90,STICK,LINETHICK3,COLOR000000;
{DRAWTEXT(VAR23>0,90,'发现大黑马加把安全锁,全部亏损问它要'), , COLORMAGENTA;}
IF(VAR24>0,-11,0),STICK,LINETHICK3, COLORRED;0,STICK,LINETHICK3, COLOR000000;
黑马线:黑马线1,STICK ,COLOR008364,LINETHICK3;

发现: (VAR18 AND VARE<-2.5 AND VAR3<5 AND VAR4=0)*60,LINETHICK2 ,COLORYELLOW;
黑马: IF(FILTER(VAR19,1)=1,1,0)*80,STICK , LINETHICK2, COLORF0F000;
大黑马: VAR19 AND VAR18*80,STICK ,LINETHICK2, COLORYELLOW;
操盘手: VAR4,COLORF00FF0;
庄拉: IF(FILTER((VAR1A OR VAR1B) AND VAR4<40 AND VAR3<40,5)=1,35,0),LINETHICK2,COLORRED ;

{DRAWTEXT(发现>0,25,'短线黑马2.5%')COLORCC99FF;
DRAWTEXT(黑马>0,52,'黑马发现10%'), COLORYELLOW;
DRAWTEXT(大黑马,70,'★日线专用大黑马获利10%以上'),COLORRED;}
0,LINETHICK1,COLOR000999;
100, COLORFF9966;

 

相关文章