在线检测未来函数

通达信兄弟投机指标公式

来源:Internet,编辑:股旁网,2010-05-24

{参数:
N 2 90 9
M1 2 30 3
M2 2 30 3}
{投机指标}
TJZB1:100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLOR0080FF;
TJZB2:100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORGREEN;
TJZB3:100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),COLORFF8000;
TJZB4:100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLOR00FFFF;
{经典KDJ}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
{波段雄鹰}
VAR5E:=LLV(LOW,26);
VAR6E:=HHV(HIGH,34);
VAR7E:=EMA((CLOSE-VAR5E)/(VAR6E-VAR5E)*4,4)*25;
DRAWTEXT(VAR7E<10,10,'底'),COLORWHITE;
DRAWTEXT(VAR7E>90,90,'顶'),COLORGREEN;
{三色必杀}
VVAR1:=(C-MA(C,6))/MA(C,6)*100;
VVAR2:=(C-MA(C,24))/MA(C,24)*100;
VVAR3:=(C-MA(C,32))/MA(C,32)*100;
VVAR4:=(VVAR1+VVAR2+VVAR3)/3;
VVAR5:=EMA(VVAR4,5);
VVAR6:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
VVAR7:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VVAR8:=VVAR7<REF(VVAR7,1) AND V>REF(V,1) AND C>REF(C,1);
AK:=EMA(VVAR5,5)*4;
AD:=EMA(AK,5),COLORMAGENTA,LINETHICK2;
AJ:=AK*3-AD*2,COLORYELLOW,LINETHICK2;
看多:IF(LLV(VVAR6,3)<VVAR6,-15,DRAWNULL),LINETHICK2,COLORRED;
看空:IF(VVAR6=LLV(VVAR6,3),-15,DRAWNULL),LINETHICK2,COLORGREEN;
短线:IF(AJ>AD,-10,DRAWNULL),LINETHICK2,COLORCC66FF;
超短线:IF(VVAR8>0,-5,DRAWNULL),LINETHICK2,COLORYELLOW;
不定区:IF(AJ<AD,-10,DRAWNULL),LINETHICK2,COLORFF9900;
牛熊战区:IF(VVAR8=0,-5,DRAWNULL),LINETHICK2,COLOR6B8E23;
{黑马侦探}
W:=((-((100)*(HHV(H,14) - C))/(HHV(HIGH,14) - LLV(L,14))));
A2:=MA(C,18);
A3:=(C-A2)/A2*100>=-9.9 AND C<A2;
RRV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RRG1:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*1;
SKK:=EMA(SMA(RRG1,3,1),2);
SDD:=SMA(SKK,3,1);
WAR4:=SMA(RRV,3,1);
WAR5:=SMA(WAR4,3,1);
腰线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
KKA:=EMA(C-L,5) ;
顶线:=MA((C+REF(C,1)+REF(C,1))/3+KKA,5);
底线:=MA(REF(C,1)-KKA,5);
MA20:= MA(C,20);
BBA:=MA(C,2);
CCA:=MA(C,10);
DDA:=MA(C,20);
EEA:=EXIST(CROSS(BBA,CCA) AND CROSS(BBA,DDA),1);
VAAR6:="KDJ.J#WEEK"(9,3,3);
VAAR8:="KDJ.J#MONTH"(9,3,3);
DEA7:="MACD.DEA#WEEK";
DIFF7:="MACD.DIF#WEEK";
D7:=DIFF7-DEA7;
DEA8:="MACD.DEA#MONTH";
DIFF8:="MACD.DIF#MONTH";
D8:=DIFF8-DEA8;
P:=(HIGH+LOW+CLOSE)/3;
CCI1:=(P-MA(P,14))*1000/(15*AVEDEV(P,14)),COLORRED;
CCI2:=(P-MA(P,36))*1000/(15*AVEDEV(P,36)),COLORGREEN;
DRAWTEXT(CROSS(VAAR6,0) AND D8>0 OR CROSS(VAAR8,0) AND D7>0,70,'黑马抄底'),COLOR0000FF;
DRAWTEXT(CROSS(W,-2) AND CROSS(WAR4,WAR5) AND CROSS(SKK,SDD),50,'天天涨停'),COLOR0000FF;
DRAWTEXT(A3 AND C/REF(C,1)>1.080,50,'美人如玉'),COLORRED;
DRAWTEXT(腰线>O AND O>底线 AND C>顶线 AND C>MA20 AND C>腰线 AND EEA AND CROSS(WAR4,WAR5) AND CROSS(SKK,SDD),50,'明月战
神'),COLORGREEN;
DRAWTEXT(CROSS(CCI1,CCI2) AND REF(CCI1,1)=LLV(CCI1,25) AND CROSS(K,D),0.4,'抄底王'),COLORYELLOW;
{庄家抬轿}
VAR1F:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1F-REF(VAR1F,1))/REF(VAR1F,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:=IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
开始控盘:=IF(A10,5,0),LINETHICK1,COLORYELLOW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR2F:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2F>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
高度控盘:=IF(VAR2F>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;
主力出货:=IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
{明月照积雪}
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
VAR4:=SMA(RV,3,1);
VAR5:=SMA(VAR4,3,1);
KK:=EMA(SMA(RG,3,1),2);
DD:=SMA(KK,3,1);
DRAWTEXT(CROSS(VAR4,VAR5) AND CROSS(KK,DD),35,'积雪'),COLOR00FFFF;
STICKLINE(CROSS(VAR4,VAR5) AND CROSS(KK,DD),0,35,1,0),COLORMAGENTA;
{兄弟波段战法}
DTJJ:=(CLOSE+HIGH+LOW)/3;
DTA:=EMA(DTJJ,10);
DTB:=REF(DTA,1);
STICKLINE(DTA>DTB,-20,-25,5,0),COLORYELLOW;
STICKLINE(DTA<DTB,-20,-25,5,0),COLORBLUE;
{黄托底蓝压顶}
VARR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR2:=REF(VARR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR3:=REF(VARR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR4:=REF(VARR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR5:=REF(VARR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR6:=REF(VARR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR7:=REF(VARR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR8:=REF(VARR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR9:=REF(VARR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARRA:=REF(VARR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARRB:=REF(VARRA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARRC:=REF(VARRB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARRD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARRE:=REF(VARRD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARRF:=REF(VARRE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR10:=REF(VARRF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR11:=REF(VARR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR12:=REF(VARR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR13:=REF(VARR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR14:=REF(VARR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR15:=REF(VARR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR16:=REF(VARR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR17:=REF(VARR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR18:=REF(VARR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR19:=REF(VARRD OR VARRE OR VARRF OR VARR10 OR VARR11 OR VARR12 OR VARR13 OR
VARR14 OR VARR15 OR VARR16 OR VARR17 OR VARR18,1) AND VARR1;
VARR1A:=REF(VARR1 OR VARR2 OR VARR3 OR VARR4 OR VARR5 OR VARR6 OR VARR7 OR
VARR8 OR VARR9 OR VARRA OR VARRB OR VARRC,1) AND VARRD;
DRAWTEXT(VARR19,20,'黄托底'),COLORYELLOW;
DRAWTEXT(VARR1A,80,'蓝压顶'),COLORLICYAN;
{红色启动}
启动线:=10*SUM(EMA((C+L)/2,2),5)/10.158,NODRAW;
平衡线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,4),NODRAW;
平台线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,10),NODRAW;
强弱线:=EMA(启动线,21);
VAR1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;
VAR2:=IF((EMA((C+L)/2,3)-VAR1)*5>0,POW((EMA((C+L)/2,3)-VAR1)*5,2)/10,-1*POW((EMA((C+L)/2,3)-VAR1)*5,2)/10);
VAR3:=IF(VAR2>0,VAR2-0,0);
STICKLINE(VAR3>0 AND REF(VAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),0,50,1,0),COLORYELLOW;
DRAWTEXT(VAR3>0 AND REF(VAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),50,'红色启动');
{短线高手}
VAR1C:=1;
VAR2C:=(2*CLOSE+HIGH+LOW)/4;
VAR3C:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4C:=LLV(LOW,5);
VAR5C:=HHV(HIGH,4);
散户:=EMA((VAR2C-VAR4C)/(VAR5C-VAR4C)*100,4)*VAR3C*VAR1C;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3C*VAR1C;
DRAWTEXT(CROSS(散户,庄家) AND 散户<50 AND 29<散户,40,'短快进'),COLOR00FF00;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,50,'低吸'),COLOR3399CC;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,95,'高抛'),COLORMAGENTA;

 

相关文章