在线检测未来函数

飞狐殷保华操盘线主图指标公式

来源:Internet,编辑:股旁网,2010-05-24

阻力价:HHV(HIGH,19),COLORGREEN,LINETHICK1;
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR2:=EMA(VAR1,9);
VAR3:=(CLOSE*2.5/100+CLOSE);
VAR4:=EMA(C,3);
VAR5:=LLV(HIGH,240);
VAR6:=100*(CLOSE-VAR5)/VAR5;
VAR7:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VAR8:=SLOPE(CLOSE,10);
DRAWTEXT(FILTER(VAR7>23,8),H,'别贪'), COLOR00FF00;
DRAWICON(COUNT(REF(VAR4,1)<REF(VAR4,2),5)=5 AND VAR4>REF(VAR4,1),L*0.98,4);
DRAWICON(FILTER(COUNT(VAR6<0,5)AND CROSS(VAR6,0)AND VAR7>REF(VAR7,1)AND VAR8>REF(VAR8,1)AND C>O,3),L,1);
DRAWICON(FILTER(REF(VAR4,1)>REF(VAR4,2)AND VAR4<REF(VAR4,1)AND VAR7>17 AND VAR1>VAR2,5),H,2);
DRAWICON(阻力价>REF(阻力价,1)AND CROSS(阻力价,VAR3)AND C<O,H*1.02,5);
input: N(5,1,9999),p1(14,1,9999);
老庄线:ma(c,n),colorred;{比半年线146大一些}
var1:=4*SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1),3.2,1);
VAR2:=LLV(LOW,27);
VAR3:=HHV(HIGH,34);
VAR4:=EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*25;
VAR5:=REF(C,2)*0.865;
VAR6:=REF(C,13)*0.772;
DSY:=100*vol/CApitAl;
注意买:=IF((Var4<10),80,100) ,color00ccff,linethick1;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
超跌:=IF(J<0,10,0),COLORFFFF00;
BDDD:=LLV(J,2)=LLV(J,8);
买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
少买:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND BETWEEN(J,20,60),1,0);
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
DRAWTEXT(少买 AND 注意买=100,low,'☆'),COLORFF00FF;
DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,low,'买★入'),COLORred;
DRAWTEXT(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),high+0.02{*1.02},'◇'),COLORwhite;
DRAWTEXT(cross(100,var1),high+0.05,'卖◆出'),color00FFFF;
DRAWTEXT(CROSS(var1,110) or CROSS(var1,120),high+0.07,'偏※高'),color00FF00;
DRAWTEXT(CROSS(var1,35) and
注意买=100,low,'☆'),colorFF00FF;
DRAWTEXT((C-MIN(VAR5,VAR6))/C<0.1 AND SUM(DSY,5)/5<1.8,low-0.05,'抄底'),color00ff00;
主筹估算:=EMA(WINNER(c)*70,3);
散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3);
筹码锁定:=散筹估算-主筹估算;
动态底部:=EMA(IF(L<=LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L- REF(l,1),0),99,1),0)*5,3);
涨:=CROSS(主筹估算,筹码锁定);
强:=CROSS(主筹估算,散筹估算);
STICKLINE(涨,O,C,8,0),COLORYELLOW;
STICKLINE(涨,O,H,0,0),COLORYELLOW;
STICKLINE(涨,L,C,0,0),COLORYELLOW;
STICKLINE(强, O,C,8,0),colormagenta;
STICKLINE(强,O,H,0,0),colormagenta;
STICKLINE(强,L,C,0,0),colormagenta;
A1:=ref(h,N)=hhv(h,2*N+1);
B1:=filter(A1,N);
C1:=backset(B1,N+1);
D1:=filter(C1,n);{高点}
A2:=ref(l,N)=llv(l,2*N+1);
B2:=filter(A2,N);
C2:=backset(B2,N+1);
D2:=filter(C2,N);{低点}
E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2;
E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND not(D2 AND E1>=E2)) OR
barstatus=2 OR barscount(c)=1;
L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2);
X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars
(if(L1,l,10000),X1));
G1:=F1>ref(F1,1);
I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}
L2:=LD OR barstatus=2 OR barscount(c)=1;
X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND
count(H2,X2)>0,hhvbars(if(H2,h,0),X2));
G2:=F2>ref(F2,1);
I2:=backset(G2,2);
HD:=I2>ref(I2,1);{过滤后高点}
R1:=backset(barstatus=2,barslast(HD)+1);
S1:=R1>ref(R1,1); {前一高}
T1:=backset(barstatus=2,barslast(LD)+1);
U1:=T1>ref(T1,1); {前一低}
R2:=backset(S1,ref(barslast(HD),1)+2);
S2:=R2>ref(R2,1); {前二高}
T2:=backset(U1,ref(barslast(LD),1)+2);
U2:=T2>ref(T2,1); {前二低}
T3:=backset(U2,ref(barslast(LD),1)+2);
U3:=T3>ref(T3,1); {前三低}
T4:=backset(U3,ref(barslast(LD),1)+2);
U4:=T4>ref(T4,1); {前四低}
R3:=backset(S2,ref(barslast(HD),1)+2);
S3:=R3>ref(R3,1); {前三高}
R4:=backset(S3,ref(barslast(HD),1)+2);
S4:=R4>ref(R4,1);
{前四高}
drawline(S2,h,S1,h,1),Coloryellow;
drawline(U2,l,U1,l,1),Colorblue;
drawline(S3,h,S2,h,1),Colorblue;
drawline(U3,l,U2,l,0),Coloryellow;
drawline(S4,h,S3,h,1),Coloryellow;
drawline(U4,l,U3,l,0),Coloryellow;
DRAWICON(S1,H*1.01,10);
DRAWICON(S2,H*1.01,10);
DRAWICON(S3,H*1.01,10);
DRAWICON(S4,H*1.01,10);
DRAWICON(U1,L*0.99,9);
DRAWICON(U2,L*0.99,9);
DRAWICON(U3,L*0.99,9);
DRAWICON(U4,L*0.99,9);
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
var6:=REF(C,1);
var7:=SMA(MAX(C-var6,0),6,1)/SMA(ABS(C-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),H*1.01,'▲逃庄'),COLORGREEN;
Var32:=CLOSE/REF(CLOSE, 1)>=1.062 AND HIGH/CLOSE<1.005 AND MA(CLOSE, 90)/CLOSE>=1.150;
Var33:=Var32 AND COUNT(Var32, 20)=1;
Var34:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
Var35:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
Var36:=IF(Var34>0.010, 0.900, 1) AND IF(Var34>(-0.025), 1,1.200);
Var37:=Var36*(Var35-Var34)*100;
Var38:=SUM(Var37,10);
Var39:=SMA(Var38, 40,1);
Var310:=Var38>20;
Var311:=CROSS(CLOSE, MA(CLOSE*1.055, 3)) AND CLOSE>OPEN*1.060 AND VOL>=REF(VOL, 1)*1.5 AND CLOSE>=MA(CLOSE,10);
Var312:=Var310 AND Var311 ;
Var313:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH, 3)-LLV(LOW, 3));
Var314:= CROSS(Var313, (-87)) AND
OPEN=1.090*REF(CLOSE, 1) AND INDEXC>0.980*REF(INDEXC, 1) AND
CLOSE<=1.470*LLV(CLOSE, 58);
Var315:=EMA(CLOSE, 12)-EMA(CLOSE,26);
Var316:=EMA(Var315,9);
Var317:=2*(Var315-Var316);
Var318:=(CLOSE-LLV(LOW, 9))/(HHV(HIGH,9)-LLV(LOW, 9))*100;
Var319:=SMA(Var318, 3,1);
Var320:=SMA(Var319, 3,1);
Var321:=EMA(IF(Var316>REF(Var316, 1), 1, (-1)),14)*14;
Var322:=EMA(IF(Var320>REF(Var320, 1), 1, (-1)),14)*14*2;
Var323:=(MA(CLOSE, 5)/MA(CLOSE,70)-1)*100;
Var324:=(Var323+Var322+Var321)/3;
Var325:=MA(CLOSE, 80)-MA(CLOSE, 10)/3;
Var326:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);{Var38>Var39;}
Var327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND Var326>0, 91, 0);
Var328:=IF(Var324>REF(Var324, 1) AND REF(Var324, 1)<REF(Var324, 2) AND (Var33 OR Var312 OR Var314) OR Var326>0 OR Var327>0, 85, 0);
Var329:=IF(Var327>0 ,95,0), STICK,LINETHICK2;
Var330:=IF(Var326>0 or var327>0,91,0), STICK,LINETHICK2;
Var331:=IF(Var328>0 or var327>0 or var326>0,88,0), STICK,LINETHICK2;
Var332:=100*(CLOSE-LLV(LOW,42))/(HHV(HIGH,42)-LLV(LOW,42)),LINETHICK1,colorgreen;
Var333:=COUNT(MA(CLOSE,3)>REF(MA(CLOSE,3),1),1)=1;
Var334:=(Var332<93 AND Var333 and MAX(MAX(Var329, Var330), Var331))*100;

 

相关文章