在线检测未来函数

通达信新版庄家抬轿指标公式

来源:Internet,编辑:股旁网,2010-05-24

REFLINE:0;
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD := 2*(DIFF-DEA);
X1:=EMA(DIFF,5)*10;
X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*10;
X3:IF(X2>0,X2,0),POINTDOT,COLORRED;
X4:IF(X2<0,X2,0),POINTDOT,COLORGREEN;
STICKLINE(X2>0,0,X2,2,1),COLORRED;
STICKLINE(X2<0,0,X2,2,0),COLORBLUE;
资金动能A:X2,COLORYELLOW,LINETHICK1;
资金动能B:X1,COLORFFFF00,LINETHICK1;
DRAWICON((CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25),资金动能B,1);
DRAWICON((CROSS(资金动能B,资金动能A) AND 资金动能A>0.25),资金动能A,2);
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*300,COLORFFCCCC,POINTDOT;
STICKLINE(控盘<0,控盘,0,0,0),COLORWHITE;
无庄控盘:控盘<0,COLORWHITE;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;
有庄控盘: 控盘>REF(控盘,1) AND 控盘>0,COLORRED;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;
主力出货: 控盘<REF(控盘,1) AND 控盘>0,COLOR00FF00;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
高度控盘: VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLORFF00FF;
A10:=CROSS(控盘,0);
开始控盘:IF(A10,2,0),COLORYELLOW,LINETHICK2;
{N:5,30,8;ZF:1,10,5;M:1.100.3;}
MA5 := MA(CLOSE,5);
MA10 := MA(CLOSE,10);
MA60 := MA(CLOSE,60);
PDAY1 := BARSLAST(CROSS(MA60,MA5));{5日均线下穿60日均线}
PDAY2 := BARSLAST(CROSS(MA60,MA10));{10日均线下穿60日均线,至此形成鸭颈部}
PDAY3 := BARSLAST(LOW=LLV(LOW,PDAY2));{形成头部,要反弹}
PDAY4 := BARSLAST(CROSS(MA5,MA10));{反弹后,5日均线和10日均线金叉}
PDAY5 := BARSLAST(CROSS(MA10,MA5));{反弹不久,5日均线和10日均线形成死叉,形成嘴部}
A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;
唐鸭头:A1 AND A2,COLORFFFF00;
NA1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
NA2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
NA3:=COUNT(V<MA(V,10),10)>6;
青龙取水:NA1 AND NA2 AND NA3,COLOR00FF00,LINETHICK2;
VAR32:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=SMA(SMA(VAR32,3,1),3,1)/28.57;
VAR34:=EMA(VAR33,5);
VAR35:=3*VAR33-2*VAR34;
绝买:CROSS(VAR35,VAR33) AND VAR33<2.1 AND C>O,COLORRED;
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
的卢:=ZDHM OR ZHM,COLORGREEN;
转盘:IF(的卢,-3,0),COLORGREEN,LINETHICK2;
DRAWTEXT(的卢,-3,'转盘'),COLORGREEN;
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113,COLORRED;
A12:=C>MAX(MA111,MAX(MA112,MA113)),COLORRED;
A13:=V/MA(V,30)>1.2,COLORRED;
A14:=C/REF(C,1)>1.049,COLORRED;
芙蓉:=A11 AND A12 AND A13 AND A14,COLORWHITE;
芙蓉盘:IF(芙蓉,-2,0),COLORLIMAGENTA,LINETHICK2;
DRAWTEXT(芙蓉,-2,'芙蓉'),COLORLIMAGENTA;
M:=REF(RSI,2)>REF(RSI,3) AND REF(RSI,2)>REF(RSI,1) AND RSI>REF(RSI,1)
AND MA(RSI,3)>REF(MA(RSI,3),1)+1 AND REF(MA(RSI,3),2)-REF(MA(RSI,3),1)>-1
AND REF(RSI,1)<REF(MA(RSI,3),1) AND REF(RSI,2)-REF(MA(RSI,3),2)>-3
AND REF(RSI,1)<38 AND RSI<EMA(RSI,25)+6 AND 100*(C-REF(C,1))/REF(C,1)<8;
DRAWICON(M,X4,3);

 

相关文章