在线检测未来函数

通达信k线同图月周日主图指标公式

来源:Internet,编辑:股旁网,2010-05-24

第一步,建立一个引用公式“001引用”( 引用公式不单独使用)
C1:C;
O1:O;
H1:H;
L1:L;
第二步,导入本公式
◆月周日K线同图◆{需要与"001引用"公式配套使用}
WC:="001引用.C1#WEEK"LINETHICK0;
WO1:=IF(WEEKDAY<REF(WEEKDAY,1),O,DRAWNULL);
WO:=HHV(WO1,WEEKDAY),LINETHICK0;
WH:=HHV(H,WEEKDAY),LINETHICK0;
WL:=LLV(L,WEEKDAY),LINETHICK0;
MC:="001引用.C1#MONTH"LINETHICK0;
MO1:=IF(DAY<REF(DAY,1),O,DRAWNULL);
MO:=HHV(MO1,DAY),LINETHICK0;
A:=DAY<REF(DAY,1);
B:=BARSLAST(A)+1;
MH:=HHV(H,B),LINETHICK0;
ML:=LLV(L,B),LINETHICK0;
STICKLINE(MC>=MO,MO,MC,4,0),COLOR5CA8FD;
STICKLINE(MC<MO,MO,MC,4,0),COLOR008B00;
STICKLINE(WC>=WO,WO,WC,4,0),COLOR003399;
STICKLINE(WC<WO,WO,WC,4,0),COLOR993300;
{JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:SMA(JC,5,1),CIRCLEDOT,COLORGREEN;
IF(C>=参考价,参考价,DRAWNULL),CIRCLEDOT,COLOR0000FF;价:}
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L),LINETHICK0;
明日支撑:=L+(C-GJ),LINETHICK0;
今日阻力:IF(ISLASTBAR,REF(明日阻力,1),DRAWNULL),POINTDOT,LINETHICK4,COLORMAGENTA;
今日支撑:IF(ISLASTBAR,REF(明日支撑,1),DRAWNULL),POINTDOT,LINETHICK4,COLORMAGENTA;
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);

 

相关文章