在线检测未来函数

通达信田福看庄指标公式

来源:Internet,编辑:股旁网,2010-05-24

RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*200500;
RSV1:=(CLOSE-LLV(LOW,2))/(HHV(HIGH,2)-LLV(LOW,2))*250000;
RSV2:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100000;
W01:=(2*CLOSE+HIGH+LOW);
W02:=EMA(W01,4);
W03:=EMA(W02,4);
W04:=EMA(W03,4);
X0:((W04-REF(W04,1))/REF(W04,1)*100)*40000;
STICKLINE(X0>=0,X0,0,8,0),COLORFF0080;
STICKLINE(X0<0,X0,0,8,0),COLORGREEN;
BIAS61 :(CLOSE-MA(CLOSE,9))/MA(CLOSE,9)*820000-30,LINETHICK0;
快:MA(BIAS61,3),COLORBLUE,LINETHICK3;
IF(快>REF(快,1) OR BIAS61>快,快,DRAWNULL),COLORFFFFFF,LINETHICK3;
K1C:=SMA(RSV1,5,1);
D1C:=SMA(K1C,5,1);
J1:=3*K1C-2*D1C;
AA1:=EMA(J1,3);
AA2:=REF(AA1,1);
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
DD1:=AA1>AA2 AND BB1>BB2;
买入:=DD1 AND NOT(REF(DD1,1)) AND (AA1<50 OR BB1<50) ;
DRAWICON(田买入,-80000,9);
福卖出:=REF(DD1,1)=1 AND NOT(DD1),LINETHICK0;
DRAWICON(福卖出,100005,6);
STICKLINE(BB1>BB2,BB2+快,快,2.5,0),COLOR0000AA;
STICKLINE(BB1>BB2,BB2+快,快,0.5,0),COLOR0055FF;
STICKLINE(BB1<=BB2,BB2,快,2.5,0),COLORFF7700;
STICKLINE(BB1<=BB2,BB2,快,0.5,0),COLORFFFF55;
K1:=SMA(RSV,3,1);
D1:=SMA(K1,3,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;
TGLXS:=(TFXXS-REF(TFXXS,1));{田福看庄}
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),快,TGLXS+快,2.5,0),COLOR0000AA;
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),快,TGLXS+快,0.5,0),COLOR0055FF;
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),快,TGLXS+快,2.5,0),COLOR0000AA;
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),快,TGLXS+快,0.5,0),COLOR0055FF;
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),快,TGLXS+快,2.5,0),COLOR00AAFF;
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),快,TGLXS+快,0.5,0),COLOR00FFFF;
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),快,TGLXS+快,2.5,0),COLORFF7700;
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),快,TGLXS+快,0.5,0),COLORFFFF55;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,快,TGLXS+快,8,0),COLORBROWN;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,快,TGLXS+快,8,0),COLORWHITE;
BIAS6 :=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*3000,LINETHICK0;
STICKLINE(BIAS6<REF(BIAS6,1),快,BIAS6+快,2.5,0),COLORFF7700;
STICKLINE(BIAS6<REF(BIAS6,1),快,BIAS6+快,1.5,0),COLORFFAA22;
STICKLINE(BIAS6<REF(BIAS6,1),快,BIAS6+快,0.5,0),COLORFFFF55;
田福:STICKLINE(C,145463,145463,5.5,0.5),COLOREEEE00;
看庄:STICKLINE(C,-40000,-40000,5.5,0.5),COLOR00C5C0;
DRAWLINE(快>=HHV(快,21),快,快<=LLV(快,21),快,1),COLOR00FF00;
STICKLINE(快>REF(快,1),快,快,3,0),COLORC0C0C0,LINETHICK3;

 

相关文章