在线检测未来函数

通达信一条线的主力轨迹指标公式

来源:Internet,编辑:股旁网,2010-05-24

用法:寻找M、W、N结构!其余的自己领会。

AA:=AMO/((H-L)*2-ABS(C-O));
买量:=IF(C>O,AA*(H-L),IF(C<O,AA*((H-O)+(C-L)),AMO/2)),LINETHICK0;
卖量:=IF(C>O,0-AA*((H-C)+(O-L)),IF(C<O,0-AA*(H-L),0- AMO/2)),LINETHICK0,COLORCYAN;
大单动向:=买量+卖量,COLOR00FFFF,NODRAW;
DTZ:ABS(大单动向)/AMO;
0.4;
{M结构}
MJG:=CROSS(0.4,DTZ) AND CROSS(REF(DTZ,1),0.4) AND
CROSS(0.4,REF(DTZ,2)) AND CROSS(REF(DTZ,3),0.4);
{W结构}
WJG:=CROSS(DTZ,0.4) AND CROSS(0.4,REF(DTZ,1)) AND
CROSS(REF(DTZ,2),0.4) AND CROSS(0.4,REF(DTZ,3));
{N结构}
NJG:=CROSS(DTZ,0.4) AND REF(DTZ,1)<REF(DTZ,2) AND
REF(DTZ,3)<REF(DTZ,1) AND REF(DTZ,2)<=0.4;
DRAWTEXT(MJG,0.75,'M'),COLORYELLOW;
DRAWTEXT(WJG,0.25,'W'),COLORRED;
DRAWTEXT(NJG,0.25,'N'),COLORWHITE;

 

相关文章