在线检测未来函数

通达信BIAS优化版指标公式

来源:Internet,编辑:股旁网,2010-05-24

N:=9;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2))*0.70828;
主动卖盘:=(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,0-VAR1*(HIGH-LOW),0-VOL/2))*0.63275;
VA:=(主动买盘+主动卖盘);
VVV:=IF((DATE > 17374085120),0,1);
AVPRICE:=((CLOSE + OPEN + LOW + HIGH)/(4))*(VVV);
成交金额:=(VA)*(AVPRICE);
A:=(SUM(成交金额,N) + 0.001)/(SUM(VA,N) + 0.001);
乖离线:=(((AVPRICE - A))/(MAX(AVPRICE,A)))*(VVV);
STICKLINE((乖离线 > 0),0,乖离线,3,0),COLORRED;
STICKLINE((乖离线 < 0),0,乖离线,3,0),COLORFF0000;
长期:(CLOSE-MA(A,55))/MA(A,55)*100,COLORYELLOW,STICK,LINETHICK3;
IF(长期<=0,长期,0),COLORWHITE,STICK,LINETHICK3;
中期:(CLOSE-MA(A,34))/MA(A,34)*100,COLORFF00FF,STICK,LINETHICK3;
IF(中期<=0,中期,0),COLORFFFF33,STICK,LINETHICK3;
短期:(CLOSE-MA(A,13))/MA(A,13)*100,COLORRED,STICK,LINETHICK3;
IF(短期<=0,短期,0),COLORBLUE,STICK,LINETHICK3;
VAR2:=REF(HIGH,1)*1.1;
VAR3:=HIGH*1.1;
VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;
VAR5:=REF(LOW,1)*0.9;
VAR6:=LOW*0.9;
VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;
VAR8:=EMA(VAR7,30);
VAR9:=EMA(VAR4,30);
VAR10:=VAR9-2;
VAR11:=IF(CLOSE<=VAR8,VAR10,VAR9);
VAR12:=VAR11*2.5;
VAR13:=VAR10*2.5;
STICKLINE(VAR12=VAR13,中期,0,4,1),COLOR66FF99;
上通道:MA(短期,20)+1.618*STD(长期,20),COLOR0099FF,LINETHICK2;
下通道:MA(短期,20)-1.618*STD(长期,20),COLOR0099FF,LINETHICK2;
生命轨迹:短期,COLOR00FF00;

 

相关文章