在线检测未来函数

通达信徐氏MACD指标公式

来源:Internet,编辑:股旁网,2010-05-24

SHORT:=6;
LONG:=9;
MID:=3;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK1,COLOR0000FF;
DEA:EMA(DIF,MID);
DRAWBAND(DIF,RGB(500,180,280),DEA,RGB(380,280,180));
MACD:(DIF-DEA)*2,COLORSTICK;
向上:=IF(DIF>=REF(DIF,1),DIF,DRAWNULL),LINETHICK2,COLORRED;
向下:=IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(DIF,DEA) AND DIF>REF(DIF,1) AND DEA<0,DIF,0);
强势区:=IF((EVERY(向下>=REF(向下,1),1)),-0.2,0)COLOR0000FF,LINETHICK3;
买入信号:IF(((CROSS(-0.01,强势区))AND DIF<0),0.2,0),STICK,COLORFF9150,LINETHICK3;
{徐氏MACD条件选股公式}
SHORT:=6;
LONG:=9;
MID:=3;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
向下:=IF(DIF<REF(DIF,1),DIF,DRAWNULL);
强势区:=IF((EVERY(向下>=REF(向下,1),1)),-0.2,0);
买入信号:IF(((CROSS(-0.01,强势区))AND DIF<0),1,0);

 

相关文章