在线检测未来函数

通达信资金突破主图指标公式

来源:Internet,编辑:股旁网,2010-05-24

买线:=EMA(C,5);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(买线>=卖线 AND C<O,CLOSE,OPEN,2.5,0),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0,0),COLORFFF000;
STICKLINE(买线<卖线,CLOSE,OPEN,3,1),COLOR00FF00;
STICKLINE(买线<卖线 AND C<O,CLOSE,OPEN,2.5,0),COLOR00FF00;
JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));
成本:IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE) /3,120));
Z1:=REF(HIGH,4)=HHV(HIGH,2*4+1);
Y1:=FILTER(Z1,3);
C1:=BACKSET(Y1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1);
V2:=FILTER(A2,3);
C2:=BACKSET(V2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F11:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F11>REF(F11,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU2:=BACKSET(ISLASTBAR=1,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
突破线:=REF(H,BARSLAST(VV2));
持仓线:=REF(H,BARSLAST(XX2));
TP1:=CROSS(C,突破线);
TP2:=CROSS(C,持仓线);
STICKLINE(TP1,O,C,4,1),COLORYELLOW;
DRAWTEXT(TP1,突破线,'←←←←'),LINETHICK1,COLORYELLOW;
STICKLINE(TP2,O,C,4,1),COLORYELLOW;
DRAWTEXT(TP2,持仓线,'←←←'),LINETHICK1,COLORYELLOW;
涨:IF(卖线>=REF(卖线,1),卖线,DRAWNULL),POINTDOT,COLORMAGENTA,LINETHICK8;
跌:IF(卖线<REF(卖线,1),卖线,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK8;
F1:=ZIG(C,8);
F3:=IF(F1>=REF(F1,1),0,100);
VARP1:=(CLOSE+LOW+HIGH)/3;
VARP2:=SUM(((VARP1-REF(LOW,1))-(HIGH-VARP1))*VOL/100000/(HIGH-LOW),0);
VARP3:=EMA(VARP2,1);
JCS:=VARP3;
JCM:=MA(VARP3,10);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击流量,3);
资金流量:=LLJX,COLORRED,LINETHICK2;
XXX:=F3=0 AND(CROSS(资金流量,0) AND CROSS(JCS,JCM));
YYY:=(F3=0 AND CROSS(REF(资金流量,1),0) AND CROSS(JCS,JCM));
ZZZ:=(F3=0 AND CROSS(资金流量,0) AND CROSS(REF(JCS,1),REF(JCM,1)));
DRAWTEXT(XXX OR YYY OR ZZZ,L*0.97,'买入'),COLORYELLOW;

 

相关文章