在线检测未来函数

通达信金牌主力指标公式

来源:Internet,编辑:股旁网,2010-05-24

操作说明:红色曲线表示金牌主力控盘强度及盘面发展趋势,黄色曲线表示大户强力支持主力控盘做庄,粉红曲线线表示散户积极拥护主力做庄,力挺大户做多,
青色曲线则表示金牌主力打压洗盘或顺势出货,白色曲线则代表中户做空且大批散户接盘.

{参数设置 : N 最小 1 最大 200 缺省值 89 ; K 最小 1 最大 200 缺省值 3}

做庄意愿:SUM(HIGH-OPEN,N)/SUM(OPEN-LOW,N)+L*21.618,COLORRED;
大户做多意愿:=MA(做庄意愿-L,5),COLORLIRED,LINETHICK2;
散户跟庄意愿:=MA(做庄意愿-L,13),COLORLIGREEN,LINETHICK2;
DRAWBAND(大户做多意愿,RGB(155,50,50),散户跟庄意愿,RGB(0,100,50));
主力控盘:IF(做庄意愿>REF(做庄意愿,1),做庄意愿,DRAWNULL),COLORRED;
散户托盘:IF(大户做多意愿>散户跟庄意愿,散户跟庄意愿,DRAWNULL),COLORMAGENTA,LINETHICK2;
大户多头:=IF(大户做多意愿>散户跟庄意愿,大户做多意愿,DRAWNULL),COLORYELLOW,LINETHICK2;
大户做多:IF(大户多头>REF(大户多头,1),大户多头,DRAWNULL),COLORYELLOW,LINETHICK2;
主力做空:IF(做庄意愿=REF(做庄意愿,1),做庄意愿,DRAWNULL),COLORLIBLUE,LINETHICK2;
大户做多翻空:IF(大户多头<=REF(大户多头,1),大户多头,DRAWNULL),COLORWHITE,LINETHICK3;
散户接盘:IF(大户做多意愿<散户跟庄意愿,大户做多意愿,DRAWNULL),COLORWHITE,LINETHICK2;
大户狂抛:IF(大户做多意愿<散户跟庄意愿,散户跟庄意愿,DRAWNULL),COLORBLUE,LINETHICK2;
散户狂抄底:IF(散户接盘<=REF(散户接盘,1),散户接盘,DRAWNULL),COLORWHITE,LINETHICK2;
大户空翻多:IF(散户接盘>REF(散户接盘,1),散户接盘,DRAWNULL),COLORYELLOW,LINETHICK3;
出货:IF(做庄意愿<REF(做庄意愿,1),做庄意愿,DRAWNULL),COLORLIBLUE;
VAR2D:=(3*CLOSE+LOW+OPEN+HIGH)/6;
多头线:=(20*VAR2D+19*REF(VAR2D,1)+18*REF(VAR2D,2)+17*REF(VAR2D,3)+16*
REF(VAR2D,4)+15*REF(VAR2D,5)+14*REF(VAR2D,6)+13*REF(VAR2D,7)+12*REF(VAR2D
,8)+11*REF(VAR2D,9)+10*REF(VAR2D,10)+9*REF(VAR2D,11)+8*REF(VAR2D,12)+7
*REF(VAR2D,13)+6*REF(VAR2D,14)+5*REF(VAR2D,15)+4*REF(VAR2D,16)+3*REF(VAR2D
,17)+2*REF(VAR2D,18)+REF(VAR2D,20))/210, CIRCLEDOT;
空头线:=MA(多头线,5), CIRCLEDOT;
STICKLINE(多头线>空头线,做庄意愿*0.78618,大户做多意愿*0.78618,10,10), COLORRED;
STICKLINE(多头线<空头线,大户做多意愿*0.78618,做庄意愿*0.78618,10,10),, COLORGREEN;
DRAWICON(C>SAR(4,2,21),SAR(4,2,21)+散户托盘*0.91618,43);
DRAWTEXT(ISLASTBAR AND 散户跟庄意愿<REF(散户跟庄意愿,1),散户跟庄意愿,' ▼'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND 大户做多意愿<REF(大户做多意愿,1),大户做多意愿,' ▼'),COLORBLUE;
DRAWTEXT(ISLASTBAR AND 做庄意愿<REF(做庄意愿,1),做庄意愿,' ▼'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR AND 散户跟庄意愿>REF(散户跟庄意愿,1),散户跟庄意愿,' ▲'),COLORDD00FF;
DRAWTEXT(ISLASTBAR AND 大户做多意愿>REF(大户做多意愿,1),大户做多意愿,' ▲'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND 做庄意愿>REF(做庄意愿,1),做庄意愿,' ▲'),COLORRED;

 

相关文章