在线检测未来函数

通达信机构能量指标公式

来源:Internet,编辑:股旁网,2010-05-24

(参数: P 2 100 14 M 1 100 3)

VAR12:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR1Q:=REF(CLOSE,2);
做多能量: SMA(MAX(CLOSE-VAR1Q,0),7,1)/SMA(ABS(CLOSE-VAR1Q),7,1)*100,COLORYELLOW,LINETHICK1;
做多能量线:= SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,5,1)-8,COLORRED,LINETHICK1;
做空能量: SMA((HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100,2,1),COLORGREEN,LINETHICK1;
DRAWBAND(10,RGB(0,0,0),做空能量,RGB(0,156,96));
{P(10,1,100),A(5,1,100);}
SVOL:=INTPART(SUM(V,0)/CAPITAL);
TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;
S1:=BARSLAST(TJ0)+1;
TJ2:=S1<REF(S1,1);
S2:=IF(TJ2,REF(S1,1)+1,S1);
S3:=SUM(TJ2,0);
ZK1:="KD.K#WEEK"(9,3,3);
ZD2:="KD.D#WEEK"(9,3,3);
ZF1:="MACD.DIF#WEEK"(12,26,9);
ZA2:="MACD.DEA#WEEK"(12,26,9);
换手:=V/CAPITAL*100,LINETHICK0;
JCD:=FILTER(CROSS(ZK1,ZD2) AND REF(ZD2,1)<30,13),NODRAW;
取点:=BARSLAST(JCD);
吸筹区:=IF(取点>0 AND 取点<61,取点,0);
ZS1:=吸筹区;
ZS2:=吸筹区+1;
ZS3:=换手/5;
ZSA:=IF(ZS1>0,SUM((ZS3),吸筹区+1),0),NODRAW;
主力筹码%:=ZSA,NODRAW;
建仓天数:ZS1,NODRAW;
阶段总额(万):=SUM(AMOUNT/10000,S2)*100,NODRAW;
阶段总量(手):=SUM(V,S2)*100,NODRAW;
阶段成本(元):(阶段总额(万)/(阶段总量(手)/100)),NODRAW;
STICKLINE(换手<3,-20,-20+换手*1.5,0,0),COLORCYAN;
青冷清:(换手<3,-80,(换手-6)*4,0.0,0),COLORCYAN;
STICKLINE(换手>=3 AND 换手<7,-20,-20+换手*1.5,0,0),COLORYELLOW;
黄活跃:(换手>=3 AND 换手<7,-80,(换手-6)*4,0.0,0),COLORYELLOW;
STICKLINE(换手>=7,-20,-20+换手*1.5,0.5,0),COLORRED;
红热烈:(换手>=7,-80,(换手-6)*4,0.5,0),COLORRED;
DRAWTEXT(建仓天数,40,'建仓'),COLORGREEN;
Q:= SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),P,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),P,1);
多头:= DMP*100/Q;
转折线:=20;
空头:= DMM*100/Q;
真实波:= SMA(ABS(空头-多头)/(空头+多头)*100,M,1);
VAR11:=((((HHV(HIGH,19) - CLOSE) / (HHV(HIGH,19) - LLV(LOW,19))) * 100) - 10);
VAR22:=(((CLOSE - LLV(LOW,19)) / (HHV(HIGH,19) - LLV(LOW,19))) * 100);
VAR33:=SMA(VAR22,9,8);
红线:=SMA(VAR33,9,8);
青线:=SMA(VAR11,9,8);
转强买点:CROSS(红线,青线) AND (多头>转折线 AND 真实波>转折线);
DRAWTEXT(转强买点,28,'买点'),COLORFFFFFF;
STICKLINE(转强买点,0,85,0,0),COLORYELLOW;
股价趋势:3*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*10,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*10,5,1),3,1),LINETHICK0;
IF(做多能量>REF(做多能量,1),做多能量,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
{IF(做空能量>REF(做空能量,1),做空能量,DRAWNULL),COLORGREEN,LINETHICK2;}
VAR17:=CROSS(82,SMA(MAX(C-(REF(C,1)),0),6,1)/SMA(ABS(C-(REF(C,1))),6,1)*100);
顶部:IF(VAR17,80,85),COLORCYAN;
DRAWTEXT(VAR17,80,'顶'),COLORCYAN;
STICKLINE(CROSS(做多能量,顶部),90,85,2,0),COLORYELLOW;
DRAWTEXT(FILTER(CROSS(做多能量,顶部),21),90,'注意高位'),COLORRED;
STICKLINE(CROSS(顶部,做空能量),90,85,1,0),COLORCYAN;
DRAWTEXT(FILTER(CROSS(顶部,做空能量),21),80,'下买'),COLORCYAN;
N:=20;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:20*((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,100000000,1000000),COLOR00AAAA,LINETHICK;
DX:=(MA(DDX,5)*N)*2;
STICKLINE(DDX>0,50,50+DDX*8.5,2.5,0),COLORRED;
STICKLINE(DDX<0,50,50+DDX*8.5,2.5,0),COLORBLUE;
涨跌:=IF(BETWEEN(C,REF(C,1),H),VOL,0);
动因:=IF(BETWEEN(C,REF(C,1),L),VOL,0);
CC2:=IF(涨跌 AND 动因,0,VOL/3);
涨跌动因:3*(涨跌-(动因+CC2))/IF(CAPITAL<1,SUM(INDEXV,71),CAPITAL),LINETHICK0;
STICKLINE(涨跌动因>0,20,20+涨跌动因*18.5,2.5,0 ),COLORYELLOW;
STICKLINE(涨跌动因<0,20,20+涨跌动因*18.5,2.5,0 ),COLORBLUE;
MA1:MA(涨跌动因,N)*2;
AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);
BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);
CC:=(AA - BB);
DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100);
EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN > LOW));
A1:=DYNAINFO(6);
A22:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A3:=(VOL / WINNER(LOW));
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=((100 * (CLOSE - A5)) / (A4 - A5));
A7:=((A22 > 0) OR (A22 = 1));
A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80));
A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4));
A10:=(A8 AND A9);
进场:IF(FILTER(A8,3),5,0);
加仓:IF((FILTER(A10,3) OR EE),10,0);
STICKLINE(进场,0,10,2,0),COLORFF7700;
STICKLINE(进场,0,10,1.5,0),COLORFFDD00;
STICKLINE(进场,0,10,1,0),COLORFFEE00;
STICKLINE(加仓,0,12,2,0),COLOR1020DD;
STICKLINE(加仓,0,12,1.5,0),COLOR1020EE;
STICKLINE(加仓,0,12,1,0),COLOR1020FF;
DRAWTEXT(进场=5,10,'进场'),COLORFFFF00;
DRAWTEXT(加仓=10,12,'加仓'),COLORFFFFFF;
箱底:=TROUGH(CLOSE,10,1)*1.02;
底:=CROSS(CLOSE,箱底);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,2,1);
D:=SMA(K,2,1);
J:=3*K-2*D;
J1:=REVERSE(J);
庄:=REF(MA(C,1),10)>REF(MA(C,60),10);
进:=CROSS(J,J1) AND 庄 AND 底;
DRAWTEXT(进,做多能量-8,' 庄进'),COLORMAGENTA;
DRAWICON(进,做多能量-8,13);

 

相关文章