在线检测未来函数

通达信牛市熊市分界指标公式

来源:Internet,编辑:股旁网,2010-05-24

本公式只要的作用是:分清何时牛市何时熊市给出参考对比,知市知股,百战百胜,不求赚多,只求稳赚。
牛市由:黄、洋红、红来表示。
熊市由:绿、青色、蓝来表示。

MA5:=EMA(CLOSE,5);
MA10:=EMA(CLOSE,10);
MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,100);
大牛:STICKLINE((MA5>强弱),MA5,强弱,1,0),COLORRED;
大熊:STICKLINE((MA5<强弱),MA5,强弱,1,0),COLORGREEN;
中牛:STICKLINE((MA10>强弱),MA10,强弱,1,0),COLORMAGENTA;
中熊:STICKLINE((MA10<强弱),MA10,强弱,1,0),COLORCYAN;
小牛:STICKLINE((MA30>强弱),MA30,强弱,1,0),COLORYELLOW;
小熊:STICKLINE((MA30<强弱),MA30,强弱,1,0),COLORBLUE;
现价:C,COLORWHITE,LINETHICK3;
A:=(3*C+L+O+H)/6;
趋势:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORRED,LINETHICK2;

 

相关文章