在线检测未来函数

通达信主力动向优化指标公式

来源:Internet,编辑:股旁网,2010-05-24

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量),NODRAW;
大户能量:(大户-均量),NODRAW;
中户能量:(中户-均量),NODRAW;
散户能量:(散户-均量),NODRAW;
回:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),6,6+主力能量,1,0),COLORRED;
复:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),6,6+主力能量,1,0),COLORYELLOW;
者:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),6,6+主力能量,1,0),COLORGREEN;
用:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),6,6+主力能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,6,6),'主力'),COLORRED;
主力线:6,COLORRED;
需:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),4,4+大户能量,1,0),COLORRED;
要:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),4,4+大户能量,1,0),COLORYELLOW;
回1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),4,4+大户能量,1,0),COLORGREEN;
复1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),4,4+大户能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,4,4),'大户'),COLORYELLOW;
大户线:4,COLORYELLOW;
加1:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),2,2+中户能量,1,0),COLORRED;
分1:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),2,2+中户能量,1,0),COLORYELLOW;
者1:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),2,2+中户能量,1,0),COLORGREEN;
好:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),2,2+中户能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,2,2),'中户'),COLORMAGENTA;
中户线:2,COLORMAGENTA;
{加2:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORRED;
分2:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORYELLOW;
欢:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORGREEN;
迎:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,0.3,0.3),'散户'),COLORWHITE;}
散户线:0,COLORWHITE;
B:=ZIG(3,50/5)*1;
G:=MA(B,2);
D:=CROSS(B,G)*10;
W:=CROSS(G,B)*10;
DRAWTEXT(W=10,4,'卖' ),COLORWHITE;
DRAWTEXT(D=10,8,'买'),COLOR00FFAA,LINETHICK3,STICK;

 

相关文章