在线检测未来函数

通达信量能分析指标公式

来源:Internet,编辑:股旁网,2010-05-24

量能博弈:=C>REF(C,1) AND CROSS(VOL,MAX(MA(VOL,5),MAX(MA(VOL,10),MA(VOL,20))));
正向博弈平台:REF((HIGH+LOW+3*CLOSE)/5,BARSLAST(量能博弈)+1),NODRAW;
量能博弈平台上:=REF(HIGH,BARSLAST(量能博弈)+1);
量能博弈平台下:=REF(LOW,BARSLAST(量能博弈)+1);
博弈:=C<REF(C,1) AND CROSS(VOL,MAX(MA(VOL,5),MAX(MA(VOL,10),MA(VOL,20))));
博弈平台A:=REF((HIGH+LOW+3*CLOSE)/5,BARSLAST(博弈)-1);
博弈平台B:=REF((HIGH+LOW+3*CLOSE)/5,BARSLAST(博弈));
反向博弈平台:MIN(博弈平台A,博弈平台B),NODRAW;
博弈平台上A:=REF(HIGH,BARSLAST(博弈)-1);
博弈平台上B:=REF(HIGH,BARSLAST(博弈));
博弈平台上:=MIN(博弈平台上A,博弈平台上B);
博弈平台下A:=REF(LOW,BARSLAST(博弈)-1);
博弈平台下B:=REF(LOW,BARSLAST(博弈));
博弈平台下:=MIN(博弈平台下A,博弈平台下B);
{----------------------------------------------------------}
筹码分布:=V=HHV(V,100);
异动博弈平台:REF((H+L+3*C)/5,BARSLAST(筹码分布)),NODRAW;
异动成本上限:=REF(H,BARSLAST(筹码分布));
异动成本下限:=REF(L,BARSLAST(筹码分布));
资金分布:=AMOUNT=HHV(AMOUNT,100) AND NOT(筹码分布);
资金博弈平台:REF((H+L+3*C)/5,BARSLAST(资金分布)),NODRAW;
台上:=REF(H,BARSLAST(资金分布));
台下:=REF(L,BARSLAST(资金分布));
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,20)*(1+80/1000);
买入:=XMA(VAR1,32)*(1-100/1000);
{买:CROSS(买入,LOW),NODRAW;
卖:CROSS(HIGH,卖出),NODRAW;}
{----------------------------------------------------------}
DRAWBAND(量能博弈平台上,RGB(248,242,242),量能博弈平台下,RGB(248,242,242));
DRAWBAND(博弈平台上,RGB(70,177,63), 博弈平台下,RGB(70,177,63));
DRAWBAND(异动成本上限,RGB(250,249,8),异动成本下限,RGB(250,249,8));
DRAWBAND(台上,RGB(114,2,4),台下,RGB(114,2,4));
{=================================================}
STICKLINE(C>=O,C,O,3,0),COLOR0000AA;
STICKLINE(C>=O,C,O,2.5,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000CC ;
STICKLINE(C>=O,C,O,1,0),COLOR0000EE;
STICKLINE(C>=O,H,L,0,0),COLOR0000FF;
STICKLINE(C<=O,C,O,3,0),COLOR7B7B00;
STICKLINE(C<=O,C,O,2.5,0),COLOR909000;
STICKLINE(C<=O,C,O,1.5,0),COLORA8A800;
STICKLINE(C<=O,C,O,1,0),COLORCECE00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
高抛线:卖出,COLORGREEN,LINETHICK2;
低吸线:买入,COLORMAGENTA,LINETHICK2;
风险:100*(L-买入)/买入,NODRAW;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLOR007B00;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),2,0),COLOR009000;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),1,0),COLOR00A800;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLOR007B00;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),2,0),COLOR090000;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),1,0),COLOR00A800;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLOR007B00;
STICKLINE(卖出<LOW,OPEN,CLOSE,2,0),COLOR009000;
STICKLINE(卖出<LOW,OPEN,CLOSE,1,0),COLOR00A800;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),1.5,0),COLORCC66FF;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),1.5,0),COLORCC66FF;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,1.5,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWICON(CROSS(买入,LOW),LOW*0.95,11);
DRAWICON(CROSS(HIGH,卖出),HIGH*1.02,12);

 

相关文章