在线检测未来函数

飞狐量龙聚首指标公式

来源:Internet,编辑:股旁网,2010-05-24

DRAWGBK(1,COLORRGB(265,10,0),COLORRGB(265,10,0),0);
{龙聚首}
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15; 攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22)); LLJX:=EMA(攻击,3);
a1:=SUM(LLJX,1);a2:=SUM(LLJX,2);a3:=SUM(LLJX,3);a4:=SUM(LLJX,4);a5:=SUM(LLJX,5);
a6:=SUM(LLJX,6);a7:=SUM(LLJX,7);a8:=SUM(LLJX,8);a9:=SUM(LLJX,9);a10:=SUM(LLJX,10);
龙高1:=MAX(MAX(a1,a2),MAX(a2,a3));龙高2:=MAX(MAX(a4,a5),MAX(a5,a6));
龙高3:=MAX(MAX(a7,a8),MAX(龙高1,龙高2));龙最高:=MAX(MAX(a9,a10),龙高3),linethick0;
龙低1:=MIN(MIN(a1,a2),MIN(a2,a3));龙低2:=MIN(MIN(a4,a5),MIN(a5,a6));
龙低3:=MIN(MIN(a7,a8),MIN(龙低1,龙低2));龙最低:=MIN(MIN(a9,a10),龙低3),linethick0;
画面起点:=SYSPARAM(2); 画面终点:=SYSPARAM(3);画面K线数:=画面终点-画面起点+1;
最低:=LLV(龙最低,画面K线数);视低:最低[画面终点],COLORFF2200;
最高:=HHV(龙最高,画面K线数);视高:=最高[画面终点];0,LINEDOT,COLOR00AAAA;
今日成交量:VOL,,LINETHICK0,COLORFFBB00;
成交量最高:=HHV(VOL,画面K线数);成交量视高:=成交量最高[画面终点];
合成成交量:=VOL*((视高-视低)/成交量视高)+视低;
虚量:=IF(BARSTATUS=2,合成成交量/INDEXV*MA(INDEXV,2),合成成交量);
STICKLINE(ISLASTBAR,视低,IF(ABS(虚量)>视高,视高,ABS(虚量)),8,1),COLORYELLOW;
STICKLINE(C>REF(C,1),视低,合成成交量,8,0),Color000066;
STICKLINE(C>REF(C,1),视低,合成成交量,6,0),Color000088;
STICKLINE(C>REF(C,1),视低,合成成交量,3,0),Color0000AA;
STICKLINE(C>REF(C,1),视低,合成成交量,1,0),Color0000CC;
STICKLINE(C<=REF(C,1),视低,合成成交量,8,0),COLORFF2200;
STICKLINE(C<=REF(C,1),视低,合成成交量,6,0),COLORFF4400;
STICKLINE(C<=REF(C,1),视低,合成成交量,3,0),COLORFF6600;
STICKLINE(C<=REF(C,1),视低,合成成交量,1,0),COLORFF8800;
{资金}
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89); VAR1E:=EMA(VAR1D,30);VAR1F:=2*(VAR1D-VAR1E)*10;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);VAR21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR22:=EMA(VAR21*0.97,3);VAR23:=(HIGH+LOW+CLOSE)/3;VAR24:=(VAR23-MA(VAR23,14))/(0.015*AVEDEV(VAR23,14));
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);VAR27:=EMA(VAR26,100);VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);VAR2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR2B:=EMA(VAR2A*0.97,3);VAR2C:=(HIGH+LOW+CLOSE)/3;VAR2D:=(VAR2C-MA(VAR2C,14))/(0.015*AVEDEV(VAR2C,14));
主力资金:IF(YEAR<2020 AND VAR28>0.1,VAR29,0)*5,COLORFF33FF,LINETHICK0;
主资增:(主力资金-REF(主力资金,1)),COLORFF33FF,LINETHICK0;
拉升资金:IF(YEAR<2020 AND VAR1F>0.015,VAR20,0)/45,,COLOR00EEFF,LINETHICK0;
拉资增:(拉升资金-REF(拉升资金,1)),,COLOR00EEFF,LINETHICK0;
最高资:=HHV(IF(拉升资金>主力资金,拉升资金,主力资金),画面K线数); 视高资:=最高资[画面终点];
PARTLINE(C,主力资金*((视高-视低)/视高资)+视低),COLORff00ff,LINETHICK2;
PARTLINE(C,拉升资金*((视高-视低)/视高资)+视低),COLOR00EEFF,LINETHICK2;
{龙聚首显示}
partline(a1,a1),COLORff8888; partline(a2,a2),COLORff8888;
partline(a3,a3),COLORff8888; partline(a4,a4),COLORff8888;
partline(a5,a5),COLORff8888; partline(a6,a6),COLORff8888;
partline(a7,a7),COLORff8888; partline(a8,a8),COLORff8888;
partline(a9,a9),COLORff8888; partline(a10,a10),COLORff8888;
partline(a1>REF(a1,1),a1),COLOR0000ff;partline(a2>REF(a2,1),a2),COLOR0000ff;
partline(a3>REF(a3,1),a3),COLOR0000ff;partline(a4>REF(a4,1),a4),COLOR0000ff;
partline(a5>REF(a5,1),a5),COLOR0000ff;partline(a6>REF(a6,1),a6),COLOR0000ff;
partline(a7>REF(a7,1),a7),COLOR0000ff;partline(a8>REF(a8,1),a8),COLOR0000ff;
partline(a9>REF(a9,1),a9),COLOR0000ff;partline(a10>REF(a10,1),a10),COLOR0000ff;

 

相关文章