在线检测未来函数

飞狐主力秘密筹码指标公式

来源:Internet,编辑:股旁网,2010-05-24

{-----------------------☆功能开关------------------------}
{均线}
X1:=(EMA(C,5)-EMA(C,13))/EMA(C,13)*100;
X2:=(EMA(C,5)-EMA(C,34))/EMA(C,13)*100;
X3:=(EMA(C,5)-EMA(C,60))/EMA(C,13)*100;
X4:=(EMA(C,5)-EMA(C,120))/EMA(C,13)*100;
X5:=V/CAPITAL*(C+O+L+H)/4;
x6:=(H-MAX(C,O))-(MIN(C,O)-L)+(C-REF(C,1));
x7:=IF(x6>0,X5,0-X5);
x8:=H-MAX(C,O)-(MIN(C,O)-L);
x9:=(x7+x8)/2+C-REF(C,1);
x10:=SUM(x9,0)+100;
x11:=EMA(x10,5)+100;
x12:=EMA(x10,13)+100;
x13:=EMA(x10,34)+100;
x14:=EMA(x10,60)+100;
x15:=EMA(x10,120)+100;
x16:=(x11-x12)/EMA(C,13)*100;
x17:=(x11-x13)/EMA(C,13)*100;
x18:=(x11-x14)/EMA(C,13)*100;
x19:=(x11-x15)/EMA(C,13)*100;
x20:=(x19-x16);
x21:=(x19-x17);
x22:=(x19-x18);
y1:=3*SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1);
y2:=2*SMA(SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
y3:=y1-y2;
y4:=100-y3;
y5:=(0-(EMA(y4,1)-50))+50;
y6:=(0-(EMA(y4,12)-50))+50;
Z1:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1);
Z2:=2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
Z3:=(Z1-Z2-50)*1.032+50;
Z4:=(2*C+H+L+O)/5;
Z5:=EMA((Z4-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,13);
P0:X4-X1+x20+y5-y6,PRECISION2,,COLORYELLOW;
P1:X4-X1+x20,PRECISION2,COLORRED;
P2:X4-X2+x21,PRECISION2,COLORMAGENTA;
P3:X4-X3+x22,PRECISION2,COLORWHITE;
P4:(Z3-Z5)/2+P0,PRECISION2,COLORGREEN;
{筹码}
bb1:=SMA(ABS(L-REF(L,1)),3,1);
bb2:=SMA(MAX((L-REF(L,1)),0),3,1);
bb3:=bb1/bb2*100;
bb4:=EMA(IF(C*1.2,bb3*10,bb3/10),3);
bb5:=LLV(L,38);
bb6:=HHV(bb4,38);
bb7:=IF(LLV(L,90),1,0);
bb8:=IF(L<=bb5,(bb4+bb6*2)/2,0);
bb9:=EMA(bb8,3)/618*bb7;
{-----------------【图解模板】---------------------}
FILLRGN((P2 < P3),P2,P3),COLORBLUE;//蓝
FILLRGN((P1 < P2),P1,P2),COLORCYAN;//青
FILLRGN((P0 < P1),P0,P1),COLORGRAY;//灰
FILLRGN((P4 < P0),P4,P0),COLORWHITE;//白
FILLRGN((P2 > P3),P2,P3),COLORMAGENTA;//晶红
FILLRGN((P1 > P2),P1,P2),COLORRED;//红
FILLRGN((P0 > P1),P0,P1),COLORYELLOW;//黄
FILLRGN((P4 > P0),P4,P0),COLORGREEN;//绿
PARTLINE(RANGE(BARPOS,SYSPARAM(2),SYSPARAM(3)),0),POINTDOT,COLORCYAN;//0 横线
{筹码}
主力秘密筹码:STICKLINE(bb9,0,bb9,6,1),Color0089FF;//橙色

 

相关文章