在线检测未来函数

通达信控仓MACD指标公式

来源:Internet,编辑:股旁网,2010-05-24

{《控仓MACD》坐标参数:1.50;1.00;0.50;0.00;-0.50;-1.00;-1.50 这排数字贴在公式编辑器的坐标线长条窗内}

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;
DEA:EMA(DIF,9),COLORWHITE,LINETHICK2;
持仓段:0,COLOR00CFFF;
空仓段:0,COLORFFCCFF;
STICKLINE(DIF>DEA,-0.7,-0.9,10,1),COLOR0000FF;
STICKLINE(DIF<DEA,-0.7,-0.9,10,1),COLORFFCCCC;
DRAWTEXT(CROSS(DIF,DEA),DIF-0.1,'建仓'),COLORRED;
DRAWTEXT(CROSS(DEA,DIF),DIF+0.1,'空仓'),COLORGREEN;
MACD彩柱:(DIF-DEA)*2,COLORSTICK;
STICKLINE(((MACD彩柱<REF(MACD彩柱,1)) AND (MACD彩柱>0)),0,MACD彩柱,1,0),COLORLIBLUE,LINETHICK2;
STICKLINE(((MACD彩柱>REF(MACD彩柱,1)) AND (MACD彩柱<0)),0,MACD彩柱,1,0),COLORFF00FF,LINETHICK2;
建仓:IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK2;
加仓:IF(DIF<0,0,DIF),COLORRED,LINETHICK2;
白线破仓:IF(DIF<DEA,DIF,DEA),COLORWHITE,LINETHICK2;
趋势强弱:IF(DIF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;

通达信控仓MACD指标公式

 

相关文章