在线检测未来函数

同花顺价量MACD指标公式

来源:Internet,编辑:股旁网,2010-05-24

用法:橙色大胆做多,黄色多转空,蓝色、绿色持币

long 1 100 26
short 1 100 12
m 1 100 9
OBV:=EMA(SUM(IF(C>REF(C,1),VOL,IF(C<REF(C,1),-V,0)),0)/1000,2);
obve:=EMA(OBV,3);
DIFF:=(EMA(obve,12)-EMA(obve,26));
bbDIFF:=DIFF-REF(DIFF,1);
DEA:=EMA(DIFF,9);
bbDEA:=DEA-REF(DEA,1);
MACD:2*(DIFF-DEA);
PARTLINE(IF(C,0,0),0,colorwhite);
STICKLINE(DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,dea,8,0),LINETHICK4,Color0089FF;//{橙}
//DRAWTEXT(DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),L*0.98,"介入");
STICKLINE(DIFF>DEA,DIFF,DEA,8,0),Color0089FF;//{橙--加宽}
STICKLINE(DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DEA,8,0),LINETHICK4,colorblue;//{蓝}
STICKLINE(DIFF<DEA,DIFF,DEA,8,0),colorblue;//{蓝--加宽}
STICKLINE(DIFF>=REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DEA,8,0),LINETHICK4,Color00C500;//{绿}
STICKLINE(DIFF<REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,DEA,8,0),LINETHICK4,coloryellow;//{黄}
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,2,0),colorred;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,2,0),coloryellow;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,2,0),colorgreen;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,2,0),COLOR0099FF;
IF(C,2*(DEA-DIFF),MACD),LINETHICK2,colorgray;//{加速线}

 

相关文章