在线检测未来函数

如何寻找经典指标RSI的两次撞击或者说W底(大智慧)

来源:Internet,编辑:股旁网,2010-05-24

说这句话可能要被大伙见笑了!我本身不大懂搞指标,只是乱拼西凑一下而已,但在实际操作中我发现RSI指标确实不错,DDE或许会骗人,但她不会,而且我们散户都可以不花钱就拥有。太极圈曾有“改进RSI”中谈到RSI的两次撞击,我想应该就是我这里的W底了、、、
{大智慧新一代副图源码:}


{以下设置背景解说}
DRAWRECTABS(290,00,00,100,RGB(0,0,295)),LAYER0;
DRAWTEXTREL(5,20,' === 看势指标【势能RSI】==='),LINETHICK1,COLORRED,LAYER0;
DRAWTEXTREL(5,200,'①慢速线在50以上是强势,快速线在80以上要注意回调'),COLOR00FF00,LAYER0;
DRAWTEXTREL(5,430,'②快速线在慢速线之上趋势不破不走'),COLOR00FF00,LAYER0;
DRAWTEXTREL(5,640,'③快速线在慢速线之上一段时间后出现两种明显情况:'),COLOR00FF00,LAYER0;
DRAWTEXTREL(20,850,'W形回调可能是第二波上攻信号,M形是顶部信号'),COLOR00FF00,LAYER0;
DRAWGBK(c>0),color000000;
{以下设置RSI}
LC := REF(CLOSE,1);
快速:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORFFFFFF;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
慢速:RSI3*0.98,COLOR00FF00,LINETHICK1;
PARTLINE(慢速,快速>=慢速), COLORFF00FF,linethick2;
80,POINTDOT,colorFFBB00 ;
50,POINTDOT,colorFFBB00 ;
{以下设置W底}
银色:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
红持:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
粉变:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
绿买:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
蓝抛:=C>=L AND H>=O AND C<O;
吸筹:= 银色 AND C>O AND H>=C AND L<=O;
W底1:=REF(蓝抛,3) AND REF(吸筹,2) AND REF(吸筹,1) AND 红持;
W底2:=REF(蓝抛,3) AND REF(吸筹,2) AND REF(蓝抛,1) AND 粉变;
W底3:=REF(蓝抛,4) AND REF(吸筹,3) AND REF(蓝抛,2) AND REF(吸筹,1) AND 绿买;
W底4:=REF(蓝抛,4) AND REF(绿买,3) AND REF(蓝抛,2) AND REF(吸筹,1) AND 绿买;
W底5:=REF(蓝抛,4) AND REF(吸筹,3) AND REF(蓝抛,2) AND REF(蓝抛,1) AND 绿买;
W底6:=REF(蓝抛,3) AND REF(吸筹,2) AND REF(蓝抛,1) AND 红持;
W底7:=REF(蓝抛,5) AND REF(吸筹,4) AND REF(绿买,3) AND REF(蓝抛,2) AND REF(吸筹,1) AND 绿买;
DRAWTEXT(W底1 OR W底2 OR W底3 OR W底4 OR W底5 OR W底6 OR W底7,慢速*0.96,'↑'),align1,COLORRED,LAYER1;

{以下为W底选股:}

银色:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
红持:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
粉变:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
绿买:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
蓝抛:=C>=L AND H>=O AND C<O;
吸筹:= 银色 AND C>O AND H>=C AND L<=O;
W底1:=REF(蓝抛,3) AND REF(吸筹,2) AND REF(吸筹,1) AND 红持;
W底2:=REF(蓝抛,3) AND REF(吸筹,2) AND REF(蓝抛,1) AND 粉变;
W底3:=REF(蓝抛,4) AND REF(吸筹,3) AND REF(蓝抛,2) AND REF(吸筹,1) AND 绿买;
W底4:=REF(蓝抛,4) AND REF(绿买,3) AND REF(蓝抛,2) AND REF(吸筹,1) AND 绿买;
W底5:=REF(蓝抛,4) AND REF(吸筹,3) AND REF(蓝抛,2) AND REF(蓝抛,1) AND 绿买;
W底6:=REF(蓝抛,3) AND REF(吸筹,2) AND REF(蓝抛,1) AND 红持;
W底7:=REF(蓝抛,5) AND REF(吸筹,4) AND REF(绿买,3) AND REF(蓝抛,2) AND REF(吸筹,1) AND 绿买;
W底:=W底1 OR W底2 OR W底3 OR W底4 OR W底5 OR W底6 OR W底7;
COUNT(W底,2)>=1 ;
 

 

 

相关文章