在线检测未来函数

飞升黑马源码(大智慧)

来源:Internet,编辑:股旁网,2010-05-24

长J89:"KDJ.J"(89,3,3),COLORBLUE;
中J27:"KDJ.J"(27,3,3),COLORWHITE;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORRED;
D:SMA(K,3,1),COLORGREEN;
FILLRGN(K,D,K>D,RGB(250,0,0));
FILLRGN(K,D,K<D,RGB(255,255,0));
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A1,5);
STICKLINE(A1>黑马线,A1,黑马线,2,0),COLORFF80FF;
STICKLINE(A1<黑马线,A1,黑马线,2,0),COLORGREEN;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2));
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,-8,'大黑马');

STICKLINE( CROSS(趋势线,0)AND 黑马线<40,-5,25, 5,0),COLORFF00FF;
VAR0004:="KDJ.K#WEEK"(9,3,3);
VAR0005:="KDJ.D#WEEK"(9,3,3);
VAR0006:="KDJ.K#MONTH"(9,3,3);
VAR0007:="KDJ.D#MONTH"(9,3,3);
DRAWTEXT(CROSS(VAR0004,VAR0005),50,'周金叉'),COLORFF00FF;
DRAWTEXT(CROSS(VAR0006,VAR0007),50,'月金叉'), COLORBLUE;

VARA:=LLV(LOW,5);
VARB:=HHV(HIGH,5);
K_X:=EMA((CLOSE-VARA)/(VARB-VARA)*100,4);
D_X:=EMA(0.667*REF(K_X,1)+0.333*K_X,2);
XG:=CROSS(K_X,D_X)AND D_X<40;
DRAWICON(XG,30,7);

 

相关文章