在线检测未来函数

90日沪深SV大资金流向统计(大智慧)

来源:Internet,编辑:股旁网,2010-05-24

{流向统计-公式描述:★90日沪深SV大资金流向统计★(自定义数据)}
ZDddx:="DDx.DDx";
TODAY0:=zdddx=0;
TODAY:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT and (ORDER(1)=0 and ORDER(2)=0);
TDR:=SELFDATA('特大买入');
TDC:=SELFDATA('特大卖出');
DDR:=SELFDATA('大单买入');
DDC:=SELFDATA('大单卖出');
TLR:=IF(TODAY0,TDR,bigorder(1,3));
TLC:=IF(TODAY0,TDC,bigorder(2,3));
DLR:=IF(TODAY0,DDR,(bigorder(1,2)-bigorder(1,3)));
DLC:=IF(TODAY0,DDC,(bigorder(2,2)-bigorder(2,3)));
TDB:="GDSJ.特买";
TDS:="GDSJ.特卖";
DDB:="GDSJ.大买";
DDS:="GDSJ.大卖";
特单买:=IF(TODAY,IF(TDB=0,TLR,TDB),TLR);
特单卖:=IF(TODAY,IF(TDS=0,TLC,TDS),TLC);
大单买:=IF(TODAY,IF(DDB=0,DLR,DDB),DLR);
大单卖:=IF(TODAY,IF(DDS=0,DLC,DDS),DLC);
主单买:=特单买+大单买;
主单卖:=特单卖+大单卖;
DRAWTEXTABS(180,0,'SV大资金流向:增减(%)');
DRAWTEXTABS(350,0,'SV大资金流向:净额(万)');
eye:=(主单买-主单卖)*vol/capital*100;
eyes:=sum(eye,0);
gold:=eyes+50;
资金线:=gold;{主力资金线}
成交:=(eye* capital) * (amount/(v*100))/10000;
一日:percentbar(资金线,REF(资金线,1));
二日:percentbar(资金线,REF(资金线,2));
三日:percentbar(资金线,REF(资金线,3));
四日:percentbar(资金线,REF(资金线,4));
五日:percentbar(资金线,REF(资金线,5));
十日:percentbar(资金线,REF(资金线,10));
廿日:percentbar(资金线,REF(资金线,20));
三十日:percentbar(资金线,REF(资金线,30));
四十日:percentbar(资金线,REF(资金线,40));
五十日:percentbar(资金线,REF(资金线,50));
六十日:percentbar(资金线,REF(资金线,60));
九十日:percentbar(资金线,REF(资金线,90));
A1:=Sum(成交,1);
A2:=Sum(成交,2);
A3:=Sum(成交,3);
A4:=Sum(成交,4);
A5:=Sum(成交,5);
A10:=Sum(成交,10);
A20:=Sum(成交,20);
A30:=Sum(成交,30);
A40:=Sum(成交,40);
A50:=Sum(成交,50);
A60:=Sum(成交,60);
A90:=Sum(成交,90);
drawtextrel(0,998,'净 额');{(万)}
drawtextrel(0,999,'分 类');
drawtextrel(10,998,numtostrn(A1,2)),COLOR00FFFF;
drawtextrel(20,998,numtostrn(A2,2)),COLOR00FFFF;
drawtextrel(30,998,numtostrn(A3,2)),COLOR00FFFF;
drawtextrel(40,998,numtostrn(A4,2)),COLOR00FFFF;
drawtextrel(50,998,numtostrn(A5,2)),COLOR00FFFF;
drawtextrel(60,998,numtostrn(A10,2)),COLOR00FFFF;
drawtextrel(70,998,numtostrn(A20,2)),COLOR00FFFF;
drawtextrel(80,998,numtostrn(A30,2)),COLOR00FFFF;
drawtextrel(90,998,numtostrn(A40,2)),COLOR00FFFF;
drawtextrel(100,998,numtostrn(A50,2)),COLOR00FFFF;
drawtextrel(110,998,numtostrn(A60,2)),COLOR00FFFF;
drawtextrel(120,998,numtostrn(A90,2)),COLOR00FFFF;

{自定监控-公式描述:■■■理想超赢分类及资金进出龙虎(自定义榜数据)}
ZDddx:="DDx.DDx";
TODAY0:=ZDddx=0;
TODAY:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT and (ORDER(1)=0 and ORDER(2)=0);
TDR:=SELFDATA('特大买入');
TDC:=SELFDATA('特大卖出');
DDR:=SELFDATA('大单买入');
DDC:=SELFDATA('大单卖出');
ZDR:=SELFDATA('中单买入');
ZDC:=SELFDATA('中单卖出');
TLR:=IF(TODAY0,TDR,bigorder(1,3));
TLC:=IF(TODAY0,TDC,bigorder(2,3));
DLR:=IF(TODAY0,DDR,(bigorder(1,2)-bigorder(1,3)));
DLC:=IF(TODAY0,DDC,(bigorder(2,2)-bigorder(2,3)));
ZLR:=IF(TODAY0,ZDR,(bigorder(1,1)-bigorder(1,2)));
ZLC:=IF(TODAY0,ZDC,(bigorder(2,1)-bigorder(2,2)));
TDB:="gdsj.特买";
TDS:="gdsj.特卖";
DDB:="gdsj.大买";
DDS:="gdsj.大卖";
ZDB:="gdsj.中买";
ZDS:="gdsj.中卖";
特单买:=IF(TODAY,IF(TDB=0,TLR,TDB),TLR);
特单卖:=IF(TODAY,IF(TDS=0,TLC,TDS),TLC);
大单买:=IF(TODAY,IF(DDB=0,DLR,DDB),DLR);
大单卖:=IF(TODAY,IF(DDS=0,DLC,DDS),DLC);
中单买:=IF(TODAY,IF(ZDB=0,ZLR,ZDB),ZLR);
中单卖:=IF(TODAY,IF(ZDS=0,ZLC,ZDS),ZLC);
小单买:=1-(特单买+大单买+中单买);
小单卖:=1-(特单卖+大单卖+中单卖);
主单买:=特单买+大单买;
主单卖:=特单卖+大单卖;
散户买额:=小单买*AMOUNT/10000;
散户卖额:=小单卖*AMOUNT/10000;
散户净额:=散户买额-散户卖额;
散户买量:=小单买*VOL;
散户卖量:=小单卖*VOL;
散户净量:=散户买量-散户卖量;
散户增减:=(VOL/CAPITAL)*100*(小单买-小单卖);
散户持仓:=25+SUM(散户增减,0);
散户单差:=(小单买-小单卖)*100;{散户净买比}
散户单数比:=小单卖/小单买;
中户买额:=中单买*AMOUNT/10000;
中户卖额:=中单卖*AMOUNT/10000;
中户净额:=中户买额-中户卖额;
中户买量:=中单买*VOL;
中户卖量:=中单卖*VOL;
中户净量:=中户买量-中户卖量;
中户增减:=(VOL/CAPITAL)*100*(中单买-中单卖);
中户持仓:=25+SUM(中户增减,0);
中户单差:=(中单买-中单卖)*100;{中户净买比}
中户单数比:=中单卖/中单买;
大户买额:=大单买*AMOUNT/10000;
大户卖额:=大单卖*AMOUNT/10000;
大户净额:=大户买额-大户卖额;
大户买量:=大单买*VOL;
大户卖量:=大单卖*VOL;
大户净量:=大户买量-大户卖量;
大户增减:=(VOL/CAPITAL)*100*(大单买-大单卖);
大户持仓:=25+SUM(大户增减,0);
大户单差:=(大单买-大单卖)*100;{大户净买比}
大户单数比:=大单卖/大单买;
超大买额:=特单买*AMOUNT/10000;
超大卖额:=特单卖*AMOUNT/10000;
超大净额:=超大买额-超大卖额;
超大买量:=特单买*VOL;
超大卖量:=特单卖*VOL;
超大净量:=超大买量-超大卖量;
超大增减:=(VOL/CAPITAL)*100*(特单买-特单卖);
超大持仓:=25+SUM(超大增减,0);
超大单差:=(特单买-特单卖)*100;{超大净买比}
超大单数比:=特单卖/特单买;
主力买额:=主单买*AMOUNT/10000;
主力卖额:=主单卖*AMOUNT/10000;
主力净额:=主力买额-主力卖额;
主力买量:=主单买*VOL;
主力卖量:=主单卖*VOL;
主力净量:=主力买量-主力卖量;
主力增减:=(VOL/CAPITAL)*100*(主单买-主单卖);
主力持仓:=50+SUM(主力增减,0);
主力单差:=(主单买-主单卖)*100;{主力净买比}
主力单数比:=主单卖/主单买;
超大卖额,COLOR5B5BFF;
大户卖额,COLOR00A800;
中户卖额,COLORFEDCBA;
散户卖额,COLORFFF000;
散户买额,COLORFF9911;
中户买额,COLOR999999;
大户买额,COLOR00FF00;
超大买额,COLORFF11FF;
外盘:=sum(if(DYNAINFO(23)*close,DYNAINFO(23),0),0)*0.003906;
内盘:=sum(if(DYNAINFO(22)*close,DYNAINFO(22),0),0)*0.003906;
主动率:=(外盘-内盘)/(内盘+外盘)*100;
通吃率:=(主单买-主单卖)*VOL/VOL*100;
{机构力道:=(主单买-主单卖)*VOL/VOL*100;}
主力介入:=(主单买-主单卖)*VOL/VOL*100;
散户跟风:=(小单买-小单卖)*VOL/VOL*100;
DRAWTEXTABS(115,4,'主动率:'+NUMTOSTRN(主动率,2)),COLORFFFFFF;
DRAWTEXTABS(195,4,'单数比:'+NUMTOSTRN(ORDER(2)/ORDER(1),2)),COLORFFFFFF;
DRAWTEXTABS(265,4,'通吃率,净买比,主力介入:'+NUMTOSTRN(通吃率,2)),COLORFFFFFF;
DRAWTEXTABS(440,4,'散户跟风:'+NUMTOSTRN(散户跟风,2)),COLORFFFFFF;
{活跃度:主力买卖占流通盘的比例}
{买卖气:主力买入占总成交量比例}
{买入力度:主力5日吸筹情况}
活跃度:=(主单买+主单卖)*VOL/CAPITAL/2*100;
买卖气:=((主单买-主单卖)*VOL/VOL)*100;
买入力度:=sum(散户增减,5)*-1;
DRAWTEXTABS(530,4,'活跃度:'+NUMTOSTRN(活跃度,2)),COLORFFFFFF;
DRAWTEXTABS(605,4,'买卖气:'+NUMTOSTRN(买卖气,2)),COLORFFFFFF;
DRAWTEXTABS(685,4,'买入力度:'+NUMTOSTRN(买入力度,2)),COLORFFFFFF;
DRAWTEXTABS( 0, 0,''+YEAR+'/'+MONTH+'/'+DAY+' '+STKNAME),COLOR00FFFF;
DRAWTEXTABS(120,20,'分 类'),COLORFFFFFF;
DRAWTEXTABS(114,37,'超'),COLORFF11FF;
DRAWTEXTABS(126,36,'大'),COLOR00FF00;
DRAWTEXTABS(139,36,'主力'),COLOR00FFFF;
DRAWTEXTABS(115,52,'■'),COLOR5B5BFF;{买}
DRAWTEXTABS(125,52,'■超大'),COLORFF11FF;{卖}
DRAWTEXTABS(115,68,'■'),COLOR00A800;{买}
DRAWTEXTABS(125,68,'■大户'),COLOR00FF00;{卖}
DRAWTEXTABS(115,84,'■'),COLORFEDCBA;{买}
DRAWTEXTABS(125,84,'■中户'),COLOR999999;{卖}
DRAWTEXTABS(115,100,'■'),COLORFFF000;{买}
DRAWTEXTABS(125,100,'■散户'),COLORFF9911;{卖}
DRAWTEXTABS(170,20,'持仓%'),COLOR1199FF;
DRAWTEXTABS(170,36,NUMTOSTRN(主力持仓,3)),COLOR1199FF;
DRAWTEXTABS(170,52,NUMTOSTRN(超大持仓,3)),COLOR1199FF;
DRAWTEXTABS(170,68,NUMTOSTRN(大户持仓,3)),COLOR1199FF;
DRAWTEXTABS(170,84,NUMTOSTRN(中户持仓,3)),COLOR1199FF;
DRAWTEXTABS(170,100,NUMTOSTRN(散户持仓,3)),COLOR1199FF;
DRAWTEXTABS(210,20,'增减%'),COLORFFFF00;
DRAWTEXTABS(210,36,NUMTOSTRN(主力增减,3)),COLORFFFF00;
DRAWTEXTABS(210,52,NUMTOSTRN(超大增减,3)),COLORFFFF00;
DRAWTEXTABS(210,68,NUMTOSTRN(大户增减,3)),COLORFFFF00;
DRAWTEXTABS(210,84,NUMTOSTRN(中户增减,3)),COLORFFFF00;
DRAWTEXTABS(210,100,NUMTOSTRN(散户增减,3)),COLORFFFF00;
DRAWTEXTABS(255,20,'净额(万)'),COLOR00FFFF;
DRAWTEXTABS(255,36,numtostrn(主力净额,2)),COLOR00FFFF;
DRAWTEXTABS(255,52,numtostrn(超大净额,2)),COLOR00FFFF;
DRAWTEXTABS(255,68,numtostrn(大户净额,2)),COLOR00FFFF;
DRAWTEXTABS(255,84,numtostrn(中户净额,2)),COLOR00FFFF;
DRAWTEXTABS(255,100,numtostrn(散户净额,2)),COLOR00FFFF;
DRAWTEXTABS(315,20,'买额(万)'),COLORFF00FF;
DRAWTEXTABS(315,36,numtostrn(主力买额,2)),COLORFF00FF;
DRAWTEXTABS(315,52,numtostrn(超大买额,2)),COLORFF00FF;
DRAWTEXTABS(315,68,numtostrn(大户买额,2)),COLORFF00FF;
DRAWTEXTABS(315,84,numtostrn(中户买额,2)),COLORFF00FF;
DRAWTEXTABS(315,100,numtostrn(散户买额,2)),COLORFF00FF;
DRAWTEXTABS(380,20,'卖额(万)'),COLOR00FF00;
DRAWTEXTABS(380,36,numtostrn(主力卖额,2)),COLOR00FF00;
DRAWTEXTABS(380,52,numtostrn(超大卖额,2)),COLOR00FF00;
DRAWTEXTABS(380,68,numtostrn(大户卖额,2)),COLOR00FF00;
DRAWTEXTABS(380,84,numtostrn(中户卖额,2)),COLOR00FF00;
DRAWTEXTABS(380,100,numtostrn(散户卖额,2)),COLOR00FF00;
DRAWTEXTABS(445,20,'净量(手)'),COLOR0099FF;
DRAWTEXTABS(445,36,numtostrn(主力净量,0)),COLOR0099FF;
DRAWTEXTABS(445,52,numtostrn(超大净量,0)),COLOR0099FF;
DRAWTEXTABS(445,68,numtostrn(大户净量,0)),COLOR0099FF;
DRAWTEXTABS(445,84,numtostrn(中户净量,0)),COLOR0099FF;
DRAWTEXTABS(445,100,numtostrn(散户净量,0)),COLOR0099FF;
DRAWTEXTABS(495,20,'买量(手)'),COLOR00FFFF;
DRAWTEXTABS(495,36,numtostrn(主力买量,0)),COLOR00FFFF;
DRAWTEXTABS(495,52,numtostrn(超大买量,0)),COLOR00FFFF;
DRAWTEXTABS(495,68,numtostrn(大户买量,0)),COLOR00FFFF;
DRAWTEXTABS(495,84,numtostrn(中户买量,0)),COLOR00FFFF;
DRAWTEXTABS(495,100,numtostrn(散户买量,0)),COLOR00FFFF;
DRAWTEXTABS(550,20,'卖量(手)'),COLORFF9922;
DRAWTEXTABS(550,36,numtostrn(主力卖量,0)),COLORFF9922;
DRAWTEXTABS(550,52,numtostrn(超大卖量,0)),COLORFF9922;
DRAWTEXTABS(550,68,numtostrn(大户卖量,0)),COLORFF9922;
DRAWTEXTABS(550,84,numtostrn(中户卖量,0)),COLORFF9922;
DRAWTEXTABS(550,100,numtostrn(散户卖量,0)),COLORFF9922;
DRAWTEXTABS(605,20,'买单比'),COLOR5B5BFF;
DRAWTEXTABS(605,36,numtostrn(SUM(主单买*100,1),1)+'%'),COLOR5B5BFF;
DRAWTEXTABS(605,52,numtostrn(SUM(特单买*100,1),1)+'%'),COLOR5B5BFF;
DRAWTEXTABS(605,68,numtostrn(SUM(大单买*100,1),1)+'%'),COLOR5B5BFF;
DRAWTEXTABS(605,84,numtostrn(SUM(中单买*100,1),1)+'%'),COLOR5B5BFF;
DRAWTEXTABS(605,100,numtostrn(SUM(小单买*100,1),1)+'%'),COLOR5B5BFF;
DRAWTEXTABS(650,20,'卖单比'),COLOR99FF99;
DRAWTEXTABS(650,36,numtostrn(SUM(主单卖*100,1),1)+'%'),COLOR99FF99;
DRAWTEXTABS(650,52,numtostrn(SUM(特单卖*100,1),1)+'%'),COLOR99FF99;
DRAWTEXTABS(650,68,numtostrn(SUM(大单卖*100,1),1)+'%'),COLOR99FF99;
DRAWTEXTABS(650,84,numtostrn(SUM(中单卖*100,1),1)+'%'),COLOR99FF99;
DRAWTEXTABS(650,100,numtostrn(SUM(小单卖*100,1),1)+'%'),COLOR99FF99;
DRAWTEXTABS(695,20,'单 差'),COLOR999EEF;
DRAWTEXTABS(695,36,numtostrn(主力单差,1)+'%'),COLOR999EEF;
DRAWTEXTABS(695,52,numtostrn(超大单差,1)+'%'),COLOR999EEF;
DRAWTEXTABS(695,68,numtostrn(大户单差,1)+'%'),COLOR999EEF;
DRAWTEXTABS(695,84,numtostrn(中户单差,1)+'%'),COLOR999EEF;
DRAWTEXTABS(695,100,numtostrn(散户单差,1)+'%'),COLOR999EEF;
DRAWTEXTABS(735,20,'单 比'),COLORFFFF99;
DRAWTEXTABS(735,36,numtostrn(主力单数比,1)+'%'),COLORFFFF99;
DRAWTEXTABS(735,52,numtostrn(超大单数比,1)+'%'),COLORFFFF99;
DRAWTEXTABS(735,68,numtostrn(大户单数比,1)+'%'),COLORFFFF99;
DRAWTEXTABS(735,84,numtostrn(中户单数比,1)+'%'),COLORFFFF99;
DRAWTEXTABS(735,100,numtostrn(散户单数比,1)+'%'),COLORFFFF99;

 

相关文章