在线检测未来函数

揭密主力资金和私募进场(大智慧)

来源:Internet,编辑:股旁网,2010-05-24

大智慧主力进场加仓公式:
A:=(VOL * CLOSE);
B:=(SUM(A,1) / SUM(VOL,1));
B1:=EMA(B,17);
趋势线:(B - B1) * 100 / B,COLORFF00FF;
强弱分界线:0,COLORFFFFCC;
AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);
BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);
CC:=(AA - BB);
DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100);
EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN <> LOW));
A1:=DYNAINFO(6);
A2:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A3:=(VOL / WINNER(LOW));
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=((100 * (CLOSE - A5)) / (A4 - A5));
A7:=((A2 > 0) OR (A2 = 1));
A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80));
A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4));
A10:=(A8 AND A9);
A11:=IF(FILTER(A8,3),5,0);
A12:=IF((FILTER(A10,3) OR EE),10,0);
进场:STICKLINE(A11,0,5,5,0),COLORFF7700;
加仓:STICKLINE(A12,0,15,5,0),COLORFF00FF;
STICKLINE(A11,0,5,5,0),COLORFF7700;
STICKLINE(A11,0,5,4.5,0),COLORFF8800;
STICKLINE(A11,0,5,4,0),COLORFF9900;
STICKLINE(A11,0,5,3.5,0),COLORFFAA00;
STICKLINE(A11,0,5,3,0),COLORFFBB00;
STICKLINE(A11,0,5,2.5,0),COLORFFCC00;
STICKLINE(A11,0,5,2,0),COLORFFDD00;
STICKLINE(A11,0,5,1,0),COLORFFEE00;
STICKLINE(A12,0,15,4.5,0),COLOR102099;
STICKLINE(A12,0,15,4,0),COLOR1020AA;
STICKLINE(A12,0,15,3.5,0),COLOR1020BB;
STICKLINE(A12,0,15,3,0),COLOR1020CC;
STICKLINE(A12,0,15,2.5,0),COLOR1020DD;
STICKLINE(A12,0,15,2,0),COLOR1020EE;
STICKLINE(A12,0,15,1,0),COLOR1020FF;
DRAWTEXT(A11,8,'进场'),COLORFFFF00;
DRAWTEXT(A12,17,'加仓'),COLORFFFFFF;

大智慧私募资金进场公式:
A01:=DYNAINFO( 7.000);
A02:=MA(AMOUNT / VOL /
100.000,VOL / CAPITAL);
A03:=BARSCOUNT(CLOSE);
A04:=SMA(CLOSE / HHV(HIGH, 120.000), 3.000, 1.000) *
100.000;
A05:=IF((A03 >
20.000),A04,0);
A06:=IF(((LOW > A01)),0,IF(((HIGH < A01)), 1.000,((A01 - LOW) +
0.009)

/ ((HIGH - LOW) +
0.009)));
A07:=DMA(A06,VOL / CAPITAL) *
100.000;
A08:=IF((A02 > A01),( 100.000 - A07),A07);
A09:=IF(((((A07 > 0) and (A07 > REF(A07, 1.000)))) and (A05 <=


88.000)),A07,0);
stickline((A09 >
0),0,A09,7,0),ColorFF00FF;

私募机构建仓区:IF(((CROSS(A09,0) and (OPEN <> LOW)) and (CLOSE <>

LOW)), 88.000,0),ColorFF00FF, LINETHICK0;

私募机构黄金线:A09,COLORYELLOW,LINETHICK2;

DRAWTEXT(CROSS(A09, 0.009),4,'-----注意'),Color00FF00;
DRAWICON(CROSS(A09, 0.009), 4.000, 1.000);

注意洗盘'洗盘结束'主力加速'庄家逃跑'风险'公式
DRAWTEXTABS(20,5,STKLABEL+' '+STKNAME+''),ColorFFBF00;
J1:="macd.diff";
J2:="macd.dea";
J3:="kdj.k";
J4:="kdj.d";
VL:=REF(LOW,1); VH:=REF(H,1);
Var1:=SMA(ABS(H-Vh),13,1)/SMA(MAX(H-Vh,0),13,1)*100;
Var2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
Var3:=REF(CLOSE,1);
Var4:=MA(Var2,13);
Var5:=LLV(L,34);
Var6:=SMA(MAX(CLOSE-Var3,0),6,1)/SMA(ABS(CLOSE-Var3),6,1)*100;
var7:=CROSS(93,Var6);
Var8:=EMA(IF(L<=Var5,Var4,0),3);
var9:=H>LLV(l,0)*7;
var10:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));
var11:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (var10 * 10.9);
T:FILTER(IF(var11<=var10 AND Var8>REF(Var8,1),Var8*8,0),20),LINETHICK4,STICK,ColorFF00FF;
T0:FILTER(IF(CROSS(j4,j3) and SUM(j1>REF(j1,1),3)>3,CROSS(j4,j3) and CROSS(j2,j1),0),13),STICK,Color5E8262,LINETHICK3;
T1:FILTER(CROSS(j1,j2) and vol>REF(SUM(vol,5),1),3),STICK,Color00FFFF,LINETHICK3;
T2:FILTER(var7 and C/(REF(C,1)-1)*100<>5 and var9 and vol>REF(SUM(vol,3),1),5),STICK,ColorFFFF00,LINETHICK3;
T3:FILTER(var9 and CROSS(j4,j3) and C/(REF(C,1)-1)*100<>5,22),STICK,Color00FF00,LINETHICK3;
DRAWTEXT(T0,T0,'注意洗盘'),Color5E8262;
DRAWTEXT(T,T,'洗盘结束'),ColorFF00FF;
DRAWTEXT(T1,T1,'主力加速'),Color00FFFF;
DRAWTEXT(T2,T2,'庄家逃跑'),ColorFFFF00;
DRAWTEXT(T3,T3,'风险'),Color00FF00;

 

相关文章