在线检测未来函数

黑马黄牛公式解密(大智慧L2)(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

{【黑马黄牛】指标使用说明:
短线黑马小波段中线黄牛大波澜;
短线回头中线强,寻机低吸等反弹。}
MA1:=(C+O+H+L)/4;
MA8:=MA(MA1,8);
ZQSJ:=BARSLAST(CROSS(MA1,MA8))+1;
ZRSJ:=BARSLAST(CROSS(MA8,MA1))+1;
短线:IF(ZQSJ<=ZRSJ,REF(ZRSJ,1),0),COLOR0000FF,LINETHICK2;
黑马:IF(ZQSJ<=ZRSJ,0-REF(ZRSJ,1),0),COLOR0000FF,LINETHICK2;
XXSJ:=BARSLAST(CROSS(0.8,短线))+1;
休息:IF(短线=0,XXSJ,0),COLOR00FF00,POINTDOT,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
中线:IF(J>K,J,0),COLOR00FFFF,LINETHICK2;
黄牛:IF(J>K,0-J,0),COLOR00FFFF,LINETHICK2;
强势:IF(J>K AND J>=50,50,IF(J>K,J,0)),COLORFF00FF,POINTDOT,LINETHICK0;
DXDD:=L=LLV(L,3) OR C=LLV(C,3);
回头:IF(DXDD AND COUNT(短线>0 AND 中线>=30,3)>=1,-30,0),COLORFFFFFF,LINETHICK2;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*200-100;
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*200-100;
MA2:=MA(RSI,2);
太阳:IF(MA2>90 AND RSI6>50,1,0),COLOR0000FF,POINTDOT,LINETHICK0;

{以下设置副图显示方式,大智慧L-2版本}
DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0));
FILLRGN(50,中线,中线>50 AND 中线>=REF(中线,1),RGB(255,00,0));
FILLRGN(50,中线,中线>50 AND 中线<=REF(中线,1),RGB(0,255,0));
FILLRGN(100,中线,中线>100,RGB(255,255,255));
DRAWICON(太阳,中线*1.3,12),ALIGN1;

------------------------------------------------

{以下设置副图显示方式,飞狐版本}
FILLRGN(中线>50 AND 中线>=REF(中线,1),50,中线),COLOR0000FF;
FILLRGN(中线>50 AND 中线<REF(中线,1),50,中线),COLOR00FF00;
FILLRGN(中线>100,100,中线),COLORFFFFFF;
DRAWICON(太阳,中线*1.3,10);

------------------------------------------------

{以下设置副图显示方式,通用版本}
STICKLINE(中线>50 AND 中线>=REF(中线,1),50,中线,8,0),COLOR0000FF;
STICKLINE(中线>50 AND 中线<=REF(中线,1),50,中线,8,0),COLOR00FF00;
STICKLINE(中线>100,100,中线,8,0),COLORFFFFFF;
DRAWICON(太阳,中线*1.3,3);

 

相关文章