在线检测未来函数

大智慧宝马主图指标公式

来源:Internet,编辑:股旁网,2010-05-24

input:BB(3,1,500),P1(60,1,250),P2(11,1,200);
DRAWGBK(CLOSE,STRIP(RGB(12,60,0),RGB(20,2,0),0));
{COLORRGB(12,60,0),COLORRGB(20,2,0),1);}
X1:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
X2:=EMA(X1,10);
X3:=REF(X2,1);
MA10:=MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA120:=MA(CLOSE,120);
MA250:=MA(CLOSE,250);
DRAWTEXT(FILTER(((((((CLOSE > X2) AND (0 < X2)) AND CROSS(X1,X2)) AND ((MA10 - REF(MA10,1)) > 0)) AND (CLOSE > OPEN)) AND ((X2 - REF(X2,1)) > 0)),5),(LOW - 0.23),'●关注'),color2690E5;
PO:=MA(CLOSE,P2);
MAN:=MA(CLOSE,20);
MAQ:MA(CLOSE,120);
MAE:MA(CLOSE,250);
MAD:=MA(CLOSE,480);
STICKLINE((OPEN >= CLOSE),OPEN,CLOSE,8,0),colorFFFF00;
STICKLINE((CLOSE > OPEN),OPEN,CLOSE,8,0),colorFF0000;
STICKLINE((CLOSE > OPEN),OPEN,CLOSE,8,0),colorFF0000;
STICKLINE((CLOSE > OPEN),OPEN,CLOSE,7,0),colorred;
STICKLINE((CLOSE > OPEN),OPEN,CLOSE,1.1,0),colorred;
STICKLINE((CLOSE > OPEN),OPEN,CLOSE,1.1,0),colorred;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.5,0),colorred;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.5,0),colorred;
STICKLINE((OPEN >= CLOSE),CLOSE,LOW,0.5,0),colorFFFF00;
STICKLINE((OPEN >= CLOSE),OPEN,HIGH,0.5,0),colorFFFF00;
压力:HHV(CLOSE,60),coloryellow;
VA:=CROSS(MA(CLOSE,20),MA(CLOSE,120));
VB:=(MA(CLOSE,20) > MA(CLOSE,120));
VC:=CROSS(MA(CLOSE,120),MA(CLOSE,20));
VD:=(MA(CLOSE,20) < MA(CLOSE,120));
VE:=CROSS(MA(CLOSE,20),MA(CLOSE,250));
VF:=(MA(CLOSE,20) > MA(CLOSE,250));
VG:=CROSS(MA(CLOSE,250),MA(CLOSE,20));
B0:=MA(CLOSE,3);
B01:=MA(CLOSE,4);
B1:=(((HIGH + LOW) + CLOSE) / 3);
B2:=HHV(B1,15);
B3:=LLV(B1,15);
B4:=(B2 - B3);
B5:=(MA(((B1 - B3) / B4),2) * 100);
B6:=HHV(B1,(4 * 15));
B7:=LLV(B1,(4 * 15));
B8:=(B6 - B7);
B9:=(MA(((B1 - B7) / B8),2) * 100);
BA:=HHV(B1,(16 * 15));
TB:=LLV(B1,(16 * 15));
BC:=(BA - BB);
BD:=(MA(((B1 - TB) / BC),2) * 100);
顶线:=98;
底线:=1;
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3:=(((CLOSE - LLV(LOW,18)) / (HHV(HIGH,18) - LLV(LOW,18))) * 100);
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:=((3 * VAR4) - (2 * VAR5));
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3:=(((CLOSE - LLV(LOW,18)) / (HHV(HIGH,18) - LLV(LOW,18))) * 100);
VAR4:=SMA(VAR3,9,1);
VAR6:=SMA(VAR5,5,1);
A2:=EMA(VAR4,8);
DRAWTEXT(((((CROSS(J,A2) AND VAR6) AND (A2 < 20)) AND (VAR2 > 9)) OR ((((A2 > (1 * REF(A2,1))) AND (VAR2 > 4)) AND (LOW >= OPEN)) AND (A2 < 60))),(LOW - 0.12),'●追'),colorFFFFCC;
DRAWTEXT((((CROSS(B5,底线) AND ((B0 - REF(B0,1)) > 0)) AND ((J - REF(J,1)) > 0)) AND (CLOSE >= OPEN)),(LOW - 0.12),'●短买'),colorCC99FF;
DRAWICON((VD AND VC),MA(CLOSE,120),11);
DRAWTEXT((((VA AND (HIGH < MAD)) AND (CLOSE >= MA20)) AND ((MAE - REF(MAE,1)) > 0)),LOW,'★大黑马起步'),colorFFFFFF;
支撑:LLV(OPEN,120),colorblue;
DRAWTEXT(((VE > VG) AND (CLOSE > OPEN)),LOW,'-★短线黑马'),colorFFFF00;
DRAWTEXT(FILTER((((HIGH > 压力) AND (CLOSE < 压力)) AND (CLOSE < OPEN)),5),(HIGH + 0.12),'●逃'),colorFFFF00;
DRAWTEXT(((LOW <= 支撑) AND (CLOSE >= MA20)),(LOW - 0.14),'●抄底'),colorred;
VAR1:=EMA(CLOSE,8);
VAR2:=EMA(VAR1,20);
VAR3:=CROSS(VAR1,VAR2);
VAR4:=(VAR1 < MA(CLOSE,P1));
VAR5:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
VAR6:=SMA(VAR5,5,1);
VAR7:=SMA(VAR6,8,1);
VAR8:=(CROSS(VAR6,VAR7) AND (VAR7 < 20));
VAR9:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR8);
VARA:=IF((CLOSE > 1000),VAR8,VAR9);
黑马起步:=(VAR3 AND VAR4);
DRAWTEXT(((((黑马起步 > 0) AND (CLOSE > OPEN)) AND CROSS(PO,MA20)) AND ((MA20 - REF(MA20,1)) > 0)),(LOW - 0.73),'★黑马'),colorFF0000;
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');
DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');
DRAWTEXT(FILTER((((OPEN < MA20) AND (CLOSE > MA20)) AND ((MA20 - REF(MA20,1)) > 0)),6),(LOW - 0.36),'●突破');
X4:=((REF(HIGH,1) + REF(LOW,1)) / 2);
X5:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(CROSS(X4,X5),HIGH,'●减仓');
DRAWTEXT(X9,(HIGH * 1.03),'●出货');
DRAWTEXT((黑马起步 > 0),LOW,'★出击');
SG:=EMA(HHV(HIGH,1),8);
X1:=EMA(CLOSE,8);
X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
全仓出击:=((((COUNT((X31 = 1),4) = 3) AND (X31 = 0)) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) > 0.085)) * 89);
DRAWTEXT((全仓出击 >= 89),LOW,'★半仓杀入');
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,4,1);
D:=SMA(K,5,1);
J:=((3 * K) - (2 * D));
VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);
VAR6:=MA(VAR5,3);
底部1:=IF((VAR6 < (0 - 9)),20,0);
DRAWTEXT((CROSS(J,K) AND (底部1 >= 20)),(LOW - 0.12),'●全仓');

 

相关文章