在线检测未来函数

飞升黑马和BS决策系统配套指标(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

{飞升黑马}
80,coloryellow;
20,colorred;
强弱分水岭:50,POINTDOT,colorgreen;
0,colorred,linethick1;
100,colorgreen,linethick1;

长j89:"kdj.j"(89,3,3),COLORffff00,linethick2;
中j27:"kdj.j"(27,3,3),COLOR4080ff,linethick2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),colorred,linethick2;
D:SMA(K,3,1),colorgreen,linethick2;
FILLRGN(K>=D,K,D),colorred;
FILLRGN(K<D,K,D),colorgreen;

A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A1,5);
STICKLINE(A1>黑马线,A1,黑马线,7,0),colorff80ff;
STICKLINE(A1<黑马线,A1,黑马线,7,0),COLORWHITE;

A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2));
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,'大黑马');
VERTLINE(CROSS(趋势线,0)AND 黑马线<40);
Var0004:="KDJ.K#WEEK"(9,3,3);
Var0005:="KDJ.D#WEEK"(9,3,3);
Var0006:="KDJ.K#MONTH"(9,3,3);
Var0007:="KDJ.D#MONTH"(9,3,3);
DRAWTEXT(CROSS(Var0004,Var0005),10,'周金叉'),color0000ff;
DRAWTEXT(CROSS(Var0006,Var0007),10,'月金叉'), COLOReeFF00;

VARA:=LLV(LOW,5);
VARB:=HHV(HIGH,5);
K_X:=EMA((CLOSE-VARA)/(VARB-VARA)*100,4);
D_X:=EMA(0.667*REF(K_X,1)+0.333*K_X,2);
XG:=CROSS(K_X,D_X)AND D_X<40;
DRAWICON(XG , 0, 6),ALIGN1;


 

 

相关文章