在线检测未来函数

大智慧自创K线王指标公式

来源:Internet,编辑:股旁网,2010-05-24

HHV(MA(H,13),13),colorred,LINETHICK1;
MA3:MA(CLOSE,3),colorffffff,LINETHICK0;
MA7:MA(CLOSE,7),colorYELLOW,LINETHICK0;
MA13:MA(CLOSE,13),COLORFF00FF,LINETHICK0;
MA26:eMA(CLOSE,26),COLORGREEN,LINETHICK0;
MA80:MA(CLOSE,80),POINTDOT,COLORyellow,LINETHICK0;
MA140:MA(c,140),POINTDOT,colorFF00FF,linethick0;
MA280:MA(c,280),POINTDOT,colorFFFF00,linethick0;
MA560:MA(c,560),POINTDOT,colorred,linethick1;
{k线}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
中:(MA(CLOSE,30)+MA(C,72))/2,color999999,LINETHICK0;
HLY1:中*1.1,POINTDOT,COLOR999999,LINETHICK0;
Var61:=(CLOSE*2+HIGH+LOW)/4;
Var62:=EMA(Var61,3);
Var63:=EMA(Var62,6);
L1: EMA(Var61,3),LINETHICK0;
L2: EMA(Var62,4),LINETHICK0;
L3: EMA(Var63,5),LINETHICK0;
{正常上涨}
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000ff;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0 ),COLOR0000ff;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR0000cc;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000ee;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000ff;
{正常下跌}
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0 ),COLORffFF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0 ),COLORffff00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffFF00;
{整理下跌区}
STICKLINE(L1<L2,CLOSE,LOW,0.5 ,0 ),COLORffff00;
STICKLINE(L1<L2,OPEN,HIGH,0.5 ,0 ),COLORffff00;
STICKLINE(L1<L2,CLOSE ,OPEN,8,0 ),COLORff7700;
STICKLINE(L1<L2 ,CLOSE ,OPEN,7,0 ),COLORff9900;
STICKLINE(L1<L2 ,CLOSE ,OPEN,6,0 ),COLORffbb00;
STICKLINE(L1<L2,CLOSE ,OPEN,5,0 ),COLORffcc00;
STICKLINE(L1<L2 ,CLOSE ,OPEN,4,0 ),COLORffdd00;
STICKLINE(L1<L2 ,CLOSE ,OPEN,3,0 ),COLORffee00;
STICKLINE(L1<L2 ,CLOSE ,OPEN,2,0 ),COLORffFF00;
{下跌开始}
Var44:=REF(L1,1)>L1 AND L1>L2;
STICKLINE(Var44,OPEN,LOW,0.5,0 ),COLORff0000;
STICKLINE(Var44,CLOSE,HIGH,0.5,0 ),COLORff0000;
STICKLINE(Var44,CLOSE,OPEN,8,0) ,COLOR550000;
STICKLINE(Var44,CLOSE,OPEN,7,0) ,COLOR660000;
STICKLINE(Var44,CLOSE,OPEN,6,0) ,COLOR770000;
STICKLINE(Var44,CLOSE,OPEN,5,0) ,COLOR990000;
STICKLINE(Var44,CLOSE,OPEN,4,0) ,COLORbb0000;
STICKLINE(Var44,CLOSE,OPEN,3,0) ,COLORdd0000;
STICKLINE(Var44,CLOSE,OPEN,2,0) ,COLORff0000;
{顶部钝化区}
stickline((CLOSE >= HLY1),CLOSE,LOW,0.5 ,0),colorff00ff;
STICKLINE((CLOSE >= HLY1),OPEN,HIGH,0.5 ,0),COLORff00ff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,8,0),colorff11ff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,7,0),colorff77ff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,6,0),colorff99ff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,5,0),colorffbbff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,4,0),colorffccff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,3,0),colorffddff;
stickline((CLOSE >= HLY1),CLOSE ,OPEN,2,0),colorffeeff;
{单边下跌}
STICKLINE(买线<卖线,CLOSE,LOW,0.5 ,0 ),COLOR00ff00;
STICKLINE(买线<卖线,OPEN,HIGH,0.5 ,0 ),COLOR00ff00;
stickline(买线<卖线,CLOSE ,OPEN,8,0),color003300;
stickline(买线<卖线,CLOSE ,OPEN,7,0),color005500;
stickline(买线<卖线,CLOSE ,OPEN,6,0),color007700;
stickline(买线<卖线,CLOSE ,OPEN,5,0),color009900;
stickline(买线<卖线,CLOSE ,OPEN,4,0),color00bb00;
stickline(买线<卖线,CLOSE ,OPEN,3,0),color00dd00;
stickline(买线<卖线,CLOSE ,OPEN,2,0),color00ff00;
{变盘}
stickline(cross(买线,卖线) or cross(卖线,买线),CLOSE,LOW,0.5 ,0),color00ffff;
STICKLINE(cross(买线,卖线) or cross(卖线,买线),OPEN,HIGH,0.5 ,0),COLOR00ffff;
stickline(cross(买线,卖线) or cross(卖线,买线),CLOSE ,OPEN,8,0),color00ffff;
{超跌牛熊买点}
KS:=(C-MA(C,13))/MA(C,13)*(-100);
STICKLINE(KS >=8,h*1.01,h,5,0),COLORcccccc;
{起步压力}
var56:=EMA(CLOSE,8);{起步}
var57:=EMA(var56,20);
var58:=CROSS(var56,var57);
var59:=var56<MA(CLOSE,120);
起步:= var58 AND var59;
STICKLINE(起步>0,h*1.01,h,5,0),COLOR00ff00;

 

相关文章