在线检测未来函数

宝塔天王+BOLL+5分钟权证实战(组合公式)(通达信)

来源:Internet,编辑:股旁网,2010-05-24

{**********宝塔天王**********}
VAR1:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR2:=((REF(VAR1,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
STICKLINE((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),CLOSE,REF(CLOSE,1),2,1),COLORRED;
VARD:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARE:=((REF(VARD,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
STICKLINE((((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18),CLOSE,REF(CLOSE,1),2,1),COLORGREEN;
VAR19:=(REF((((((((((((VARD OR VARE) OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18),1) AND VAR1);
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORRED;
VAR1A:=(REF((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),1) AND VARD);
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORGREEN;

周MA5:MA(C,5),COLORWHITE;
月MA20:MA(C,20),COLORYELLOW;
季MA60:MA(C,60),COLORFF11CC;
{半年MA120:MA(C,120),COLORCYAN;
年MA250:MA(C,250),COLOR0066CC;}
BOLL1:MA(CLOSE,20),COLORYELLOW,LINETHICK1,CIRCLEDOT;
UPPER:BOLL1+2*STD(CLOSE,20),COLORFF99FF,LINETHICK1,CIRCLEDOT;
LOWER:BOLL1-2*STD(CLOSE,20),COLORFF99FF,LINETHICK1,CIRCLEDOT;
{BOLL1%:(C-LOWER)/(UPPER-LOWER),COLORSTICK;}

{**********5分钟权证实战**********}
AAF:LLV(LOW,34),LINETHICK2,COLORCYAN;
BBF:MA(AAF,4),LINETHICK2,COLORYELLOW;
V1:=REF(CLOSE,1);
V2:=SMA(MAX(CLOSE-V1,0),6,1)/SMA(ABS(CLOSE-V1),6,1)*100;
STICKLINE(CROSS(76,V2),C,O,2,0) ,COLORWHITE,LINETHICK1;
DRAWTEXT(CROSS(76,V2),H*1.01,'↓') ,COLORWHITE;
A1:=REF(CLOSE, 1);
A2:=SMA(MAX((CLOSE - A1),0), 8, 1) / SMA(ABS((CLOSE - A1)), 8, 1) * 100;
A3:=SMA(MAX((CLOSE - A1),0), 55, 1) / SMA(ABS((CLOSE - A1)), 55, 1) * 100;
底1:=(((A2 <= 20) AND (A3 <= 49)) * 2);
底2:= IF(SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<12,1,0);
STICKLINE(底1=2 AND 底2=1,C,O,2,0) ,COLORFF11CC,LINETHICK1;
DRAWTEXT(底1=2 AND 底2=1,L*0.95,'↑') ,COLORFF11CC;

 

相关文章