在线检测未来函数

大智慧CCI资金指标公式

来源:Internet,编辑:股旁网,2010-05-24

{INPUT:N(34,1,100),M(3,1,100);}
个股资金指数:EMA(((100 * (CLOSE - LLV(LOW,N))) / (HHV(HIGH,N) - LLV(LOW,N))),M);
stickline(个股资金指数 > (0 - 5),100,(0 - 5),2,2),color000000;
stickline(个股资金指数 > 20,个股资金指数,20,2,2),ColorDB43E7;
DRAWICON(CROSS(个股资金指数,50),个股资金指数,10);
DRAWICON(CROSS(50,个股资金指数),个股资金指数,11);
市场资金指数:EMA(((100 * (INDEXC - LLV(INDEXL,N))) / (HHV(INDEXH,N) - LLV(INDEXL,N))),M),colorwhite;
DRAWICON(CROSS(50,市场资金指数),50,5);
DRAWICON(CROSS(市场资金指数,50),50,4);
资金运作安全区:stickline((市场资金指数 > 50),20,5,5,0),Color7BBEB2;
博弈线:80;
20;
50;

{cci}
{cci卖点对于短期内暴涨的股票卖出非常适合}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORRED,LINETHICK0;
cci高度关注:if(ref(cci,1)<-99 and cci >-98,1,0),colorwhite;
stickline(cci高度关注,20,40,6,1),linethick3,colorwhite;
cci逃逸:if(ref(cci,1)>99 and cci <98 and 个股资金指数 >45,1,0),colorgreen;
stickline(cci逃逸,80,95,6,0),linethick3,colorgreen;
弱势1:=if(cci<-100,cci/5+20,20);
stickline(弱势1,20,弱势1,1,0),linethick1,Color47FD6F;
弱势2:=if(cci<-50 and cci >-101,cci/5+20,20);
stickline(弱势2,20,弱势2,1,0),linethick1,coloryellow;
买入1:if(ref(cci高度关注,1)=1 and cci>-50,1,0);
买入2:if(ref(cci高度关注,2)=1 and cci>-50 and ref(cci,1)>-50,1,0);
买入3:if(ref(cci高度关注,3)=1 and cci>-50 and ref(cci,1)>-50,1,0);
买入4:if(ref(cci高度关注,4)=1 and cci>-50 and ref(cci,1)>-50 and ref(cci,2)>-50,1,0);
stickline(买入1,20,60,3,0),linethick1,colorred;
stickline(买入2,20,65,3,0),linethick1,colorred;
stickline(买入3,20,70,3,0),linethick1,colorred;
stickline(买入4,20,75,3,0),linethick1,colorred;
买入选股:if(买入1 or 买入2 or 买入3 or 买入4,1,0);
DRAWTEXT(买入选股,0,'买'),COLORRED;

 

相关文章