在线检测未来函数

大智慧实战主图指标公式

来源:Internet,编辑:股旁网,2010-05-24

N1:=6;N2:=12;N3:=26;
MA13:MA(CLOSE,13),COLORFF00FF,LINETHICK2;
MA17:MA(CLOSE,17),COLORBLUE,LINETHICK2;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
{买卖}
买:IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0),COLORRED,LINETHICK0;
卖:IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0),COLOR00FF00,LINETHICK0;
DRAWTEXT(filter(买=1,5),LOW-0.03,'B'),COLORRED;
STICKLINE(filter(买=1,5),HIGH,LOW,0,1),COLORRED,LINETHICK2;
STICKLINE(filter(买=1,5),OPEN,CLOSE,4,1),COLORRED,LINETHICK2;
DRAWTEXT(filter(卖=1,1),HIGH*1.02,'S'),COLOR00FF00;
STICKLINE(filter(卖=1,1),HIGH,LOW,0,1),COLOR00FF00,LINETHICK2;
STICKLINE(filter(卖=1,1),OPEN,CLOSE,4,1),COLOR00FF00,LINETHICK2;
{加仓}
加仓A:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
加仓B:=加仓A;{白K突破追涨要用}
DRAWTEXT(FILTER((CROSS(加仓A,0) AND 买<>1) OR (CROSS(CLOSE,MA13) AND 买<>1),3),LOW-0.03,'J'),COLORFF00FF;
STICKLINE(FILTER((CROSS(加仓A,0) AND 买<>1) OR (CROSS(CLOSE,MA13) AND 买<>1),3),HIGH,LOW,0,1),COLORFF00FF,LINETHICK2;
STICKLINE(FILTER((CROSS(加仓A,0) AND 买<>1) OR (CROSS(CLOSE,MA13) AND 买<>1),3),OPEN,CLOSE,4,1),COLORFF00FF,LINETHICK2;
加仓:FILTER((CROSS(加仓A,0) AND 买<>1) OR (CROSS(CLOSE,MA13) AND 买<>1),3),COLORFF00FF,LINETHICK0;
{注意}
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
注意:IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0),COLORYELLOW,LINETHICK0;
DRAWTEXT(注意 AND 卖<>1,HIGH*1.02,'谨慎'),COLORYELLOW;
STICKLINE(注意 AND 卖<>1,HIGH,LOW,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(注意 AND 卖<>1,OPEN,CLOSE,4,1),COLORYELLOW,LINETHICK2;
{机构建仓}
建仓区域:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
DRAWTEXT(建仓区域<5,LOW-0.03,'机构'),COLORFF0033;
DRAWTEXT(建仓区域<5,LOW-0.03,'加仓'),COLORWHITE;
机构建仓区:建仓区域<5,COLORFF0033,LINETHICK0;
{支撑压力线}
RSV1:=(c-LLV(low,13))/(HHV(h,13)-LLV(l,13))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
RSV2:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
支撑:IF(CROSS(J1,J2),L,REF(L,BARSLAST(CROSS(J1,J2)))),COLORRED,LINETHICK2;
压力:IF(CROSS(J2,J1),H,REF(H,BARSLAST(CROSS(J2,J1)))),COLOR00FF00,LINETHICK2;
{白K突破追涨}
DRAWTEXT((CROSS(C,压力) AND 加仓B<>加仓A) OR (CROSS(C,压力) AND 买<>1),low-0.03,'突破'),COLORWHITE;
STICKLINE((CROSS(C,压力) AND 加仓B<>加仓A) OR (CROSS(C,压力) AND 买<>1),HIGH,LOW,0,1),COLORWHITE,LINETHICK2;

 

相关文章