在线检测未来函数

指标重组主图(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

它山之石为我用,复合重组在我意.股指期货胜出,我需更加努力!
DRAWTEXTEX(c,1,5,5,'所属板块:' + BLKNAME),ALIGN4,colorred;
DD:=FINANCE( 1);
SS:=FINANCE( 7);
BL:=SS/DD*100;
GG:=FINANCE(33);
TH:=DYNAINFO(39);
JZ:=FINANCE(34);
DRAWTEXTEX(c,1,5,55,'总股本:'+NUMTOSTR(DD,0)+'万股' +' 流通A股:'
+NUMTOSTR(SS,0)+'万股'+' 流通比例:'+NUMTOSTR(BL,3)+'%'+' 市盈率:'
+NUMTOSTR(TH,2)+' 倍'+' 收益:'+NUMTOSTR(GG,3)+' 元'+' 净资产:'
+NUMTOSTR(JZ,3)+' 元'),COLORGREEN;

强撑:FORCAST(LLV(FORCAST(LOW,10),30),2),colorFF6699,linethick2;
重阻:FORCAST(HHV(l,120),2),,color00FFFF,linethick2;
阻力1:FORCAST(HHV(L,6),2),,color00FF00;
阻力2:FORCAST(HHV(l,26),2),,ColorEEEEEE;
阻力3:FORCAST(HHV(l,44),2),,ColorCCB0F3;
阻力4:FORCAST(HHV(l,67),2),,ColorFFCC00;
阻力5:FORCAST(HHV(l,87),2),,ColorFF00FF;
支撑:ma(FORCAST(llV(l,20),2),2),colorCC3333;
支撑1:FORCAST(llV(l,6),2),,color00FF00,POINTDOT,linethick3;
支撑2:FORCAST(llV(l,26),2),,ColorEEEEEE,POINTDOT,linethick3;
支撑3:FORCAST(llV(l,44),2),,ColorCCB0F3,POINTDOT,linethick3;
支撑4:FORCAST(llV(l,67),2),,ColorFFCC00,POINTDOT,linethick3;
支撑5:FORCAST(llV(l,87),2),,POINTDOT,linethick3;
二分位:(H+L)/2 ,LINETHICK4,COLORyellow,POINTDOT;
MID:=MA(CLOSE,20);
UPPER:=MID+2*STD(CLOSE,20);
LOWER:=MID-2*STD(CLOSE,20);
V1:=(CLOSE-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);
K1:=SUM(LLV(V2,4),4)/4;
V3:=EMA(V2,64)*10;
V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;
B:=V2>V4;
D:=V5>10;
E:=V3<=10 OR V2<=V4 OR V5<=10;
KS:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
RKS:=REF(KS,1);
MLS:=RKS/KS>1.23 AND RKS>13 AND CLOSE/REF(CLOSE,1)>1.03;


RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,5,0),COLORFF00FF;

天量:=VOL=HHV(VOL,0);
DRAWTEXT(天量,c,'-------高位天量卖'),COLORYELLOW;

BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9,c,'---------二次BIAS乖离底买'),COLORgreen;
换手率1:IF(CAPITAL=0,INDEXV/ESTDATA(12),VOL /FINANCE(7)),PRECISION2,LINETHICK0;
A:=MA(换手率1,2);
X0:=LLV(A,20),linethick0;
X1:=(A-LLV(A,20))=0;
换手最小:=IF(ALL (A>0,5) AND FILTERX(X1,5),X1,0),COLORRED;
小天:BARSLAST(换手最小),LINETHICK,color008888;
X2:=HHV(A,20);
X3:=(A-X2)=0;
换手最大:=IF(ALL(REF(A,1)<X2,5) AND FILTERX(X3,5),1,0),COLORGREEN;
DRAWTEXT(ALL (A>0,5)AND FILTERX(X1,5),o,'-----------换手最小'),LINETHICK3,COLORred;
DRAWTEXT(ALL(REF(A,1)<X2,5)AND FILTERX(X3,5),c,'-------换手最大 '),LINETHICK3,COLOrwhite;

hl1:winner(c)*100,colorred,linethick0;
突破:if(cross(hl1,30),100,0),colorred,linethick0;
DRAWTEXT(突破,o,'-------反弹'),coloryellow;

aa:=Close > Ref(Close, 1) and Ref(Close, 1) > Ref(Close, 2) and Ref(Close, 1) < Ref(Close, 3) and If(Ref(Close, 3) < Ref(Close, 4), 1, If(Ref(Close, 4) < Ref(Close, 5),Ref(Close, 1) < Ref(Close, 4) or( Ref(Close, 2) < Ref(Close, 4) and Ref(Close, 3) >= Ref(Close, 5) ),If(Ref(Close, 5) < Ref(Close, 6), 1,Ref(Close, 6) < Ref(Close, 7))));
bb:=Close < Ref(Close, 1) and Ref(Close, 1) < Ref(Close, 2) and Ref(Close, 1) > Ref(Close, 3) and If(Ref(Close, 3) > Ref(Close, 4), 1, If(Ref(Close, 4) > Ref(Close, 5),Ref(Close, 1) > Ref(Close, 4) or( Ref(Close, 2) > Ref(Close, 4) and Ref(Close, 3) <= Ref(Close, 5) ),If(Ref(Close, 5) > Ref(Close, 6), 1,Ref(Close, 6) > Ref(Close, 7))));
drawtext(aa and close>ref(open,2),low*0.995,'三平底翻红'),color,COLORFF00FF;
drawtext(bb and close<ref(close,2),high*1.01,'三平顶翻绿'),color00ff00;
drawicon(aa and close>ref(open,2),low,1);
drawicon(bb and close<ref(close,2),high*1.01,2);

VAR1:MD(CLOSE,1)LINETHICK0,COLORBLUE;
PARTLINE(VAR1>REF(VAR1,2),VAR1),LINETHICK2,colorred;
PARTLINE(VAR1=REF(VAR1,2),VAR1),LINETHICK2,coloryellow;
PARTLINE(VAR1<REF(VAR1,2),VAR1),LINETHICK2,coloryellow;


S下:=HHV(MA(HIGH,2),2),COLORGREEN,LINETHICK0;
S上:=LLV(MA(HIGH,2),1),COLORRED,LINETHICK0;
Sppp:=-(S上-S下)/ref(c,1)*100;
Sptem1:=(min(o,c)-l)/(h-l)*100;
Sptem2:=(h-max(o,c))/(h-l)*100;
SPTEM3:=(c-o)/(h-l)*100;
SKJ1:=(SPTEM3>49 AND SPTEM1>0.3*SPTEM2) OR SPTEM3>80;
SKJ2:=(SPTEM3<=49 AND SPTEM3>20 AND SPTEM1>SPTEM2);
SKJ3:=(SPTEM3<=20 and sptem3>-20 and sptem1>1.2*sptem2);
SKJ4:=(SPTEM3<-20 AND SPTEM3>-40 AND SPTEM1>2*SPTEM2);
SKJ:=(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4) AND (Sppp>2 or ref(Sppp,1)>2 );
短买:=if(sum(sppp>0,5)=5 and sum(skj>0,5)=0,5*(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4),5*skj),COLORRED;
DRAWTEXT(短买,L,'短买'),COLORwhite;
V2:=IF(BARSTATUS=1,VOL*240/MINUTE/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1 and c>o,O,C,3,0),COLORyellow;
STICKLINE(V2>=1 and c<o,O,C,3,0),COLORblue;
DRAWTEXT(V2 and c>o,c,'--升量'),COLORYELLOW;
DRAWTEXT(V2 and c<o,c,'--跌量'),COLORYELLOW;

x1:=(C+L+H)/3;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),
ema8,'∠45'),colorwhite;

STICKLINE(c>=COST(50)and c<=COST(58)and c>o,O,C,5,0),COLORred;
STICKLINE(c>=COST(97)and c<=COST(100)and c>o,O,C,5,0),COLORwhite;
DRAWTEXT(c>=COST(97)and c<=COST(100) and c>o,c,'--获利大于97%'),COLORred;
DRAWTEXT(c>=COST(50)and c<=COST(58) and c>o,c,'--获利50%'),COLORYELLOW;

 

相关文章