在线检测未来函数

大智慧最正确的DMI指标公式

来源:Internet,编辑:股旁网,2010-05-24

(1)强的上升趋势(牛市): PDI > MDI AND ADX >= 30 。
(2)强的下降趋势(熊市):PDI < MDI AND ADX >= 30 。
(3)略牛的盘整期:PDI > MDI AND 15< ADX < 30。
(4)略熊的盘整期:PDI < MDI AND 15 < ADX < 30。
(5)静寂期: ADX < =15 AND (PDI > MDI OR PDI < MDI) 。
(6)在牛市ADX越大越强,但是大于60就要注意了,牛市将可能要回调
PDI你可理解成牛的力量;MDI理解成熊的力量;而ADX理解成牛熊力量对比的度量没有方向性。

N=14
TR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR,COLORRED;
MDI:DMM*100/TR,COLORGREEN;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;
15;
30;

 

相关文章