在线检测未来函数

大智慧霸占大牛指标公式

来源:Internet,编辑:股旁网,2010-05-24

MA5 := MA(close,5);
MA10 := MA(close,10);
MA60 := MA(close,60);
pday1 := barslast(cross(ma60,ma5));{5日均线下穿60日均线}
pday2 := barslast(cross(ma60,ma10));{10日均线下穿60日均线,至此形成鸭颈部}
pday3 := barslast(low=llv(low,pday2));{形成头部,要反弹}
pday4 := barslast(cross(ma5,ma10));{反弹后,5日均线和10日均线金叉}
pday5 := barslast(cross(ma10,ma5));{反弹不久,5日均线和10日均线形成死叉,形成嘴部}
a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;
a2:= count(cross(ma10,ma5),pday2)=1;
唐鸭头:A1 AND A2,COLORffff00;
DRAWTEXT(唐鸭头,0.8 , '唐鸭头'),COLORred;
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,60);
Var4:=BARSLAST(CROSS(Var1,Var3));
Var5:=BARSLAST(CROSS(Var2,Var3));
Var6:=BARSLAST(HIGH=HHV(HIGH,Var5));
Var7:=BARSLAST(CROSS(Var2,Var1));
Var8:=BARSLAST(CROSS(Var1,Var2));
Var9:=Var4>Var5 AND Var5>Var6 AND Var6>Var7 AND Var7>Var8 AND Var8<5;
VarA:=COUNT(CROSS(Var2,Var1),Var5)=1;
老鸭头:Var9 AND VarA and Var3>ref(Var3,1),COLORFF00FF;
DRAWTEXT(老鸭头 ,0.8 , '老鸭头'),COLORred;
nA1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
nA2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
nA3:=COUNT(V<MA(V,10),10)>6;
青龙取水:nA1 AND nA2 AND nA3,COLOR00FF00,LINETHICK2;
DRAWTEXT(青龙取水 ,0.8 , '青龙取水'),COLORred;
线:=ma(c,180)>ref(ma(c,180),2) and count(cross(ma(c,5),ma(c,180)),6)>=1 and c/ma(c,180)>1.04,COLORblue;
穿180线:ma(c,180)>ref(ma(c,180),2) and count(cross(ma(c,5),ma(c,180)),6)>=1 and c/ma(c,180)>1.04,COLORblue;
DRAWTEXT(穿180线,0.8 , '180'),COLORblue;
VAR32:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=SMA(SMA(VAR32,3,1),3,1)/28.57;
VAR34:=EMA(VAR33,5);
VAR35:=3*VAR33-2*VAR34;
绝买:CROSS(VAR35,VAR33) AND VAR33<2.1 and c>o,COLORred;
DRAWTEXT(绝买,0.9,'绝买'),COLORred;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=if(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=ma(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
dkkj:=if(ff3<ff1,ff1,ff3);
ma13:=ma(c,13);
zdhm:=cross(c,dkkj) and cross(c,ma13) and cross(c,xkkj);
zhm:=cross(c,ma13) and cross(c,xkkj);
的卢:zdhm or zhm,COLORgreen;
DRAWTEXT(的卢,0.5,'的卢'),COLORred;
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113,COLORred;
A12:=C>MAX(MA111,MAX(MA112,MA113)),COLORred;
A13:=V/MA(V,30)>1.2,COLORred;
A14:=C/REF(C,1)>1.049,COLORred;
芙蓉:A11 AND A12 AND A13 AND A14,COLORwhite;
DRAWTEXT(芙蓉,0.3,'出水芙蓉'),COLORwhite;
J:=(C*2+H+L)/4;
K:=(EMA(J,13) - EMA(J,21))*180;
D:=EMA(K,2);
kk:=(K-D);
dd:=-1*(K-D);
ss:=CROSS(kk,dd);
VARbb:=EMA(EMA(CLOSE,5),5);
ll:=(VARbb-REF(VARbb,1))/REF(VARbb,1)*1000;
mm:=CROSS(ll,0);
黄买蓝出:ss and mm,COLORyellow;
DRAWTEXT(黄买蓝出,0.5,'黄买蓝出'),COLORred;
RSV100:=(CLOSE-LLV(LOW,HIGH)
),;1;
J10:=3*-2*
CLOSE-REF(CLOSE,1);
Var202:-REF(CLOSE,1)>=0;
Var203:=REF(CLOSE,1)-CLOSE;
Var204:=IF(CLOSE-REF(CLOSE,1)<=0,Var203,0);
Var205:=SUM(Var202,8)/SUM(Var204,8);
Var206:=1-1/(1+Var205);
Var207:=LLV(LOW,50);
Var208:=HHV(HIGH,50);
Var209:=EMA(CLOSE,2);

 

相关文章