在线检测未来函数

仿的阿洛主图源码修改添加提示(大智慧)(通达信)

来源:Internet,编辑:股旁网,2010-05-24

TYP :=(h+l+2*c)/4;
x:=WMA(TYP,3);
II1:=DMA(TYP,BETA(35));
均线1:SLOPE(ii1*3-REF(ii1,5),3)+C,colorffff00,layer0,LINETHICK2;

H均线:=wMA(h,3);
L均线:=wMA(L,3);
转折线:IF(C>REF(H均线,1),L均线-(eMA(l,2)-WMA(l,2)),IF(C<REF(L均线,1),H均线+(eMA(h,2)-WMA(h,2)),L)),LINETHICK2,colorffffFF,LAYER2;
M8:=EMA(C,8);
M13:=EMA(C,13);
FILLRGN(M8,M13,M8>M13,RGB(255,155,0));
看多:C>转折线,linethick0,color0000ff;
看空:C<=转折线,linethick0,color00ff00;
看空期:=BARSLAST(看多);
看多期:=BARSLAST(看空);
预买:看多期=1,color00ffff,linethick0;
清仓:看空期=1,colorblue,linethick0;

STICKLINE(C>转折线,H,L,0,0),colorred;
STICKLINE(C>转折线,O,C,8,0),colorred;
STICKLINE(C>转折线 AND C<O,O,C,8,1),colorred;
STICKLINE(C<=转折线,H,L,0,0),color00ff00;
STICKLINE(C<=转折线,O,C,8,0),color00ff00;
STICKLINE(C<=转折线 AND C>O,O,C,8,1),color00ff00;
STICKLINE(预买,O,(C+O)/2,8,0),color00ffff;
STICKLINE(清仓,O,(C+O)/2,8,0),colorFF6600;
DRAWICON(预买 AND 均线1>转折线,转折线,1),ALIGN1,LAYER0;
DRAWICON(BARSLAST(均线1<转折线)=1 AND C>转折线,转折线,7),ALIGN1,LAYER1;
DRAWICON(清仓 AND 均线1<转折线 AND 转折线>O,转折线*1.06,2),ALIGN1,LAYER0;
DRAWICON(C>转折线 AND 均线1<REF(H,1) AND C<REF(C,1),H*1.05,8),ALIGN1,LAYER1;

通达信的请用下面这段源码!

A:=(H+L+2*C)/4;
X:=XMA(A,3);
II1:=DMA(X,BETA(35));
快线:SLOPE(II1*3-REF(II1,3),3)+C,COLORFF9900;
上升线:=EMA(X,1);
SDX:HHV(上升线,1),LINETHICK2,COLORRED;
XDX:LLV(上升线,2),LINETHICK2,COLORGREEN;
乾坤:IF(SDX>XDX,DRAWNULL,MA(XDX,3)),LINETHICK2,COLORFFFFFF;
否泰:IF(XDX<MA(XDX,34),DRAWNULL,MA(XDX,34)),LINETHICK2,COLOR00FFFF;
兑泽:IF(MA(XDX,34)<MA(XDX,136) OR XDX<MA(XDX,136),DRAWNULL,MA(XDX,136)),LINETHICK2,COLORFFFF00;XIUGA

 

相关文章