在线检测未来函数

发一个简单的MACD公式(通达信)

来源:Internet,编辑:股旁网,2010-05-24

用法:红色柱——底背离;黄色柱——低位金叉;紫色柱——二次金叉。其它趋势均有提示。取自网上,加以合成修改,以供判断。
源码:实用MACD
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9),COLOR33CCFF;
DRAWBAND(DIF,RGB(155,50,50),DEA,RGB(0,100,50));
MACD:(DIF-DEA)*2,COLORSTICK,COLORMAGENTA;

K1:=BACKSET(DIF>REF(DIF,1),2);
持仓:IF(K1,DIF,DRAWNULL),COLORRED,LINETHICK1;
K2:=BACKSET(DIF<REF(DIF,1),2);
空仓:IF(K2,DIF,DRAWNULL),COLOR33FF33,LINETHICK1;
STICKLINE(持仓,0,0,2,0),COLORRED;
STICKLINE(空仓,0,0,2,0),COLORGREEN;

STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,0,1),COLORRED;
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,0,1),COLORMAGENTA;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,0,1),COLOR33CCFF;
STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,0,1),COLOR33FF33;


多头趋势:=IF(DIF>=0 AND MACD>=0 OR (DIF<0 AND MACD>=0),1,0);
空头趋势:=DIF<0 AND MACD<0 OR (DIF>=0 AND MACD<0);
缩头:=IF(MACD>0 AND REF(MACD,1)>REF(MACD,2) AND MACD< REF(MACD,1),1,0);
缩脚:=IF(MACD<0 AND REF(MACD,1)< REF(MACD,2) AND MACD>REF(MACD,1),1,0);
阻力:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),1,0);
支撑:=IF(CROSS(MA(C,20),C) OR CROSS(MA(C,60),C),1,0);
做多:=IF(CROSS(DEA,DIF) AND DIF>0 AND DEA>0,1,0);
放空:=IF(CROSS(DIF,DEA) AND DIF<0 AND DEA<0,1,0);
趋势:IF(DEA<1000,DEA,DRAWNULL),COLOR33CCFF,LINETHICK1;

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低位金叉,0,0.1,2,0),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.2,2,0),COLORFF80FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.1,2,0),COLORRED;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;

 

相关文章